Can only get into emergency session after recent upgrades

I’ve been (unsuccessfully) attempting to get in to my desktop (Plasma) after some kernel and other updates (systemd may be another culprit). As of Thursday evening (fine the last day) I’m dropped to an emergency session. Hard to gather details as I can only get into the session some of the time, most of the time key presses from the keyboard don’t seem to register. I’ve noticed odd behavior after trying to look at kernels loaded from a certain path. I noticed this after running sudo dracut. I replaced mkinitcpio by removing the latter and installing dracut, eos-dracut, and kernel-install-for-dracut. I tried reinstalling the kernel via arch-chroot. DIdn’t work. I tried running sudo dracut and uname -a shows kernel 6.1.0 when 6.1.1 and not 6.1.0 is installed under /lib/modules.
System logs - HW Info:
journalctl -b -1:

Any help is appreciated as I’m not quite sure what the culprit is in this case.

You definitely don’t want all those installed. Also, running sudo dracut won’t do anything useful.

Are you using grub or systemd-boot?

Grub. I dual boot with Win11. No systemd-boot.

You should remove the package kernel-install-for-dracut.

Then run sudo dracut-rebuild. If you don’t have access to your system, arch-chroot in first.

Thanks. I will try that ASAP but it might be till 5 PM EST Saturday by the time I can try it.

Well I tried running “sudo dracut rebuild” and it gave an error. The terminal output was:

[root@EndeavourOS /]# sudo dracut rebuild
dracut: Cannot find module directory /lib/modules/6.0.12-arch1-1/
dracut: and --no-kernel was not specified

That should be dracut-rebuild not dracut rebuild

Should mention I’m chrooted in using arch-chroot via Live USB. Here is more terminal output:

[root@EndeavourOS /]# sudo dracut-rebuild
sudo: dracut-rebuild: command not found

Do you still have eos-dracut installed?

Yes. I’ve checked via sudo pacman -S eos-dracut. Net change was 0MiB.

What does pacman -Ql eos-dracut show?

Weird. Said package was not found. I’ll just install it. Thought it was installed. Now I’ve ran sudo dracut-rebuild. I’ll reboot and see what happens. Edit: still being dropped to an emergency shell. Shell reports kernel 6.1.0 is installed, via uname -a but I think it’s supposed to be on 6.1.1. if I cd to /lib/modules and type ls I see6. 1.1-arch-1 and others in 6.0.x and 5.15.x and 5.19.x but not 6.1.0. Maybe it’s trying to boot 6.1.0 but it’s missing kernel module libraries or something? Update: I reinstalled grub and that seems to have fixed most things - but now Windows 11 isn’t being picked up for some reason by grub.

Reinstalling grub and running the 2 commands it suggested got dual boot working again. Fixed. Thanks for the help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.