Can not uninstall protonup

So a few days ago i installed protonup from the terminal and now when i am trying to remove it…umm for some reason it isnt uninstalling

I have tried 4 different methods but to no avail →

[megumi@Akimegumi ~]$ sudo pacman -Rs protonup
error: target not found: protonup

[megumi@Akimegumi ~]$ sudo pacman -Rns protonup
error: target not found: protonup

[megumi@Akimegumi ~]$ sudo pacman -R protonup
error: target not found: protonup

[megumi@Akimegumi ~]$ yay -R protonup
error: target not found: protonup
→ exit status 1

Obviously, protonup is not the name of the package.

$ pacman -Q | grep proton

might reveal the name of the package you want to uninstall.


$ yay -Ss protonup
aur/protonup-ng-git 0.1.4.r2.gf60ee76-1 (+2 1.05)
Install and Update Proton-GE, a version for the new naming convention
aur/protonup-git 0.1.4.r2.gf60ee76-1 (+5 0.22)
Install and Update Proton-GE
aur/protonup-qt 2.7.4-1 (+20 5.85)
Install and manage Proton-GE and Luxtorpeda for Steam and Wine-GE for Lutris

i tried it and it showed me this error =>

[megumi@Akimegumi ~]$ sudo pacman -Q | grep proton:
Sorry, try again.

The : shouldn’t be on the end.


Which command did you use to install it?


Many here would like to know how exactly you installed it.
Anyway, you can see the package name with many ways, e.g.

yay -Qs protonup
pahis  # then search: /protonup
grep protonup /var/log/pacman.log | tail -n1

This happens when you pick from a list and then do not remember the name, I do it all the time (I blame my age!!!).

As far as i can see there are only 3 protonup packages. :thinking:


Are you sure you used pacman to install it and not some other package manager like pip?

The package you are normally using for protonup is protonup-qt, as @ricklinux already mentioned.

Therefor your syntax should be:

sudo pacman -R protonup-qt

Edit: Should you have taken one of the others then you have to adjust it of course. @ricklinux has listed them all so you can just copy them to try them out :slight_smile:

1 Like