Can I reinstall Endeavour without losing my software?

I have a 500GB SSD that is in 2 partitions now. I’d like to have it all in 1 partition for endeavour Cinnamon that I am using on this machine. On my KDE install on the other machine, I did something similar and it worked, just can’t remember what I did.
Should I delete the first partition and unified it with the 2nd that is Endeavour or reinstall with some option to not erase my software apps already installed?

In order to provide a better answer, can you share the output of:

sudo parted -l
sudo parted -l
NAME    SIZE TYPE MOUNTPOINT UUID                                 FSTYPE LABEL
sda   465,8G disk                                                        
│     245,2G part            93a7d153-cb36-4e39-85c2-d8846be2f47a ext4   rootMX19
│         2G part            691e1015-446c-4b11-8db3-959e5850af6a swap   
      218,5G part /          12293d57-22e8-4e10-a877-9129afd67204 ext4   
sr0   600,7M rom                             

SDA3 is my Endeveaour install.

So…you want to remove the mx19 install and make the whole disk available for EndeavourOS?

Yes, I installed MX to try it out and it’s just sitting there.

You shouldn’t need to reinstall.

You can just delete the partitions you don’t need and expand the other. To give you more explicit instructions, can you provide two more things?

sudo parted -l
cat /etc/fstab
Model: ATA WDC WDS500G2B0A (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  263GB  263GB   primary  ext4
 3      263GB   498GB  235GB   primary  ext4
 2      498GB   500GB  2147MB  primary  linux-swap(v1)

Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Error: /dev/sr0: unrecognised disk label
Model: MATSHITA DVD-RAM UJ8FBS (scsi)                                     
Disk /dev/sr0: 630MB
Sector size (logical/physical): 2048B/2048B
Partition Table: unknown
Disk Flags: 

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=12293d57-22e8-4e10-a877-9129afd67204 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

OK, that should be pretty easy. The swap partition is only used for mxlinux so you don’t need it either.

I would do it this way:

  • Backup up your important data in case something goes wrong
  • Boot off a live ISO
  • Using gparted
    • Delete the swap partition and the mx partition (sda1 & sda2)
    • Expand sda3 to use the whole disk
    • Apply the changes
  • Reboot

That should be all that it is needed.

If when you reboot you get an error that the disk is missing, it could mean the UUID changed. In that case, post back and we can help you troubleshoot and fix that.

Either way, don’t skip the backup your data step. It is a pretty simple process but whenever you mess with your disk there is some chance of data loss.


Thanks. I’ll start the back up

Also, just to be totally clear, make sure you are backing up to a different disk.


What about GRUB, will it auto generate a new one?

After you reboot and everything is confirmed working you can run:

sudo grub-mkconfig -o /boot/grub/grub.cfg
1 Like

GRUB loading
Welcome to Grub!
error: no such partition
grub rescue>

should I type this in?

sudo grub-mkconfig -o /boot/grub/grub.cfg

You need to boot off the live ISO again and use arch-chroot on your install. Then you can type that in.

So, after you boot the live ISO:

sudo mount /dev/sda3 /mnt
sudo arch-chroot /mnt

Then you should get # prompt.

Then you can run:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then reboot

1 Like

same error.
it displayed an error while creating the grub file but it was too quick, something about sda1

Your partition device has changed to /dev/sda1?
Could you show the lsblk command output again?

Here is the error:

[liveuser@eos-2020.09.20 ~]$ sudo mount /dev/sda3 /mnt
[liveuser@eos-2020.09.20 ~]$ sudo arch-chroot /mnt
[root@archiso /]# sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your

and here is lsblk

loop0 7:0 0 1.7G 1 loop
sda 8:0 0 465.8G 0 disk
└─sda3 8:3 0 465.8G 0 part /
sdb 8:16 1 14.4G 0 disk
├─sdb1 8:17 1 1.8G 0 part
└─sdb2 8:18 1 64M 0 part
sr0 11:0 1 600.7M 0 rom

I think I have to rename sda3 to sda1?

That error is about /dev/sdb1 which is the ISO. I am not sure that is related.

I think you should reinstall grub.

Go back into the chroot and then:

grub-install --target=i386-pc /dev/sda3