Calamares installer not detecting primary SSD

Hello, I’m a long-time lurker and first time poster.

Yesterday, I started my rig and was unable to start normally or from the fallback with systemd-boot. I shrugged and grabbed the installer stick, and nuked my rig. (Recent install, backups available, no worries.)

My rig has a storage SATA HDD (sda) and a primary M.2 SSD (sdb). Both are detected by pretty much everything and I can mount them, partition them, write, and read on them. SSD SMART status is high hours but good.

The EOS Calamares installer detects the USB and HDD just fine, but not the SSD.

No RAID, everything should be set to UEFI, I don’t have any weird dual boot shenanigans, and every device has been clean partitioned to EXT4.

https://0x0.st/XZ-i.csv

Any assistance will be appreciated.

What does sudo parted -l show?

Output

Model: ATA ST3000DM001-1ER1 (scsi)
Disk /dev/sda: 3001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 3001GB 3001GB ext4

Model: ATA WDC WDS100T2B0B- (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 1000GB 1000GB ext4

Model: USB SanDisk 3.2Gen1 (scsi)
Disk /dev/sdc: 61.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 2688MB 2855MB 167MB primary fat16 esp

So it is detected by the OS but the installer doesn’t see it?

Do you need the data on that partition? If not try deleting it and launching the installer with an empty disk.

I didn’t so that was one of the first things I tried. I re-nuked using a different method just to be sure.

But did you leave it unpartitioned or did you create a new partition? I am suggested you leave it unpartitioned.

Just retried with both drives unpartitioned. No change.

So the other drive isn’t in the dropdown box at the top of the window?

If it isn’t there, can you share the installer log?

The SSD is missing from the dropdown.

https://0x0.st/XZax.txt

It looks like it is detected:

    LIST OF DETECTED DEVICES: 
    .. node	capacity	name	prettyName 
    .. "/dev/sda" 3000590369280 DevName$3206b42e DevNamePretty$68683e2a 
    .. "/dev/sdb" 1000202273280 DevName$ea847c6c DevNamePretty$93e12b0b 
    .. 2 devices detected. 

The installer is listing the storage HDD and the installer USB drive.

It will only show the first drive by default…

I knew about the drop-down list but I took another much closer look just to be sure. Turns out that if the drive model text string is long enough, it truncates the drive size so instead of seeing drive model - 931.51 GB I was seeing drive mod…31.51 GB, which is only a bit bigger than a cheap USB drive, so I was incorrectly assuming it was the USB drive.

Mystery solved. The problem was meat-related. I am terribly sorry. Thank you for the help.

A reasonable assumption =)
Would’ve been confused as well.