Calamares installer ask for a min of 2.4GB ram to install the OS, im on a 2GB machine

Hi using endeavorous on a machine and going good, but trying to install it on a 2gb ram machine and Calamares installer gives a condition of 2.4gb min of RAM (not shure if it was 2.4 but something like that).

Seams strange since i testest manjaro and many distros on that machine.

Does anybody know it it may be a work around ?


Edit /etc/calamares/modules/welcome_online.conf before launching the installer and lower the ram requirement.

gonna try it thanks!

1 Like

The other option is to install offline and switch to the DE of your choosing afterwards.

Modifying the config file worked perfect. But an error went on the installation.

Bootloader installation error

The bootloader could not be installed. The installation command

grub-install --target=i386-efi --efi-directory=/boot/efi --bootloader -id=endeavouros-2822 --force

returned error code 1

Could this be that I previously tried to install arch but got into GRUB problems and gave up …?

should mention that im installing it on a baytrail laptop asus x205ta that has an uefi 32bit bootloader on an 64bit processor

I think the problem is with calamares since manjaro has the same problem, probably has to do with the 32bit bootloader on 64bit processor.



All Arch based distrobutions do not support i386/i686 architechture processors. . . I do not know 100% on bootloader, but I would assume that is also true.

You can checkout or I know I’ve personally used Debian/MX linux on 32 recently that was pretty damn decent still.

No, 32-bit efi with 64-bit cpu can work on Arch-based. You don’t need arch32 for this.

1 Like

Hmm. Well, now I know I guess. This must be a pretty rare setup. Very cool there’s a workaround keeping the old stuff alive!

It is most commonly Bay Trail processors.

They are older but not as old as you may think. They are still being sold today.

aside from the fact that you have a 32bit boot machine we will set this RAM minimum restriction lower for next release… it seems to be a huge issue where calamares crashes or simply stuck if less than 2GB of RAM on VM installs mostly, and you can install just fine on real hardware if there is at least 2GB RAM for online installs and offline will work also with 1.5GB.


Yes, after modifing the welcome_online the process went ok till the bootloader part at the end but thats an issue with bay trail computers, ill try to get that working with the previous comment of daito.


Thanks Dalto, looks like there is not a straight forward solution yet, right?

As far as I understand it, there are workarounds, but nothing straightforward. That being said, I don’t have one of these devices so I have never tried it myself.

1 Like

In the past, I’ve been able to install Manjaro on a T100CHI (a similar baytrail also from Asus), using the method referenced deep down in dalto’s link. I was also able to make a bootable Garuda ISO, but 2GB was not enough RAM for the Garuda liveUSB to run stably much less install. The endeavour ISO is structured differently than Garuda/Manjaro ISOs, so I am unfamiliar with how to modify it.

Calamares can install grub for uefi32 if it finds the i386-efi grub modules, usually at /boot/grub/i386-efi/. It may be possible to copy those files after starting the Endeavour liveUSB perhaps from an MX-Linux ISO.

thanks, but it looks like endeavourOs doesnt comes with the boot/grub folder (relating to the thread on the link that tells to edit the /boot/grub/grub.cfg should i create that folder? idont thinks so right?

The endeavour ISO appears to use syslinux to boot, so there won’t be a grub.cfg to edit. What I meant was to boot the endeavour ISO/liveUSB and then try to copy the modules before installing. You might have to create that folder.

I haven’t done an endeavour install on a baytrail, but I can share what obstacles I’ve encountered in the past with other distros. YMMV. Most of the hurdles were getting the liveUSB to boot!

1 Like

yes yes i understood what you meant thats why i said “referring to the thread on the link”

Thanks, im trying different things now to see what works did not tried what you mentioned but im considering it : ) as an option

ill share how it goes :+1:

1 Like