Cairo Dock

TLDR;
This is because of the scaling of my laptop, Cairo Dock was opening out of the radius of the screen, when i changed scaling back to 1 it works.
@OdiousImp has found the thread for the bug describing the UI scaling issue.
@freebird54 has written an article about HiDPI using XFCE.

Does anyone else have any issues when first running Cairo Dock?

So I’ve installed it via AUR (cairo-dock and cairo-dock-plug-ins) and whenever I run it, it comes up with the message about OpenGL, if I click Yes, to run it with OpenGL, I’m unable to interact with it, if I click No, it runs but it’s off screen and only 1/4 of it is showing (I’ll see if I can add some pictures for examples), when I finally get it on screen by holding ALT and dragging, I make it so it should be on the bottom via configure settings, then it’s off screen again, however so much so, I can’t see it.

I then change it to “Left” position, and it’s half off screen so I’m able to move it again, just not at the bottom position.

I’ve rambled a bit here so apologies.

Basically… Where can I find the conf file to change the default location when setting the positions, because currently I can’t choose Bottom as it starts off screen.

Thanks!

if i install cairo i install from repository… which desktop / videocard are you running?

Try to run it without a backend at all
cairo-dock &
Or run it with cairo’s own backend
cairo-dock -c

OpenGL doesn’t support all video cards that’s what’s cairo has it’s own.

DE: XFCE4 and
Videocard: Intel (Don’t have the exact model to hand, but it’s a Surface Book 2)

Thanks! I tried both and both I got more functionality out, however when I move the dock to the bottom position, it still disappears, lots in the terminal about parsing markup errors.

Is there anything that I can put on there that would be of help as I’m being a typical dummy user at the moment by giving no information.

However… since playing around, I learnt that Cairo dock is more than just a dock, it has notification areas and application launchers, it’s pretty much a lightweight DE haha.

‘Downgrading librsvg from 2:2.42.4-1 to 2:2.42.3-1 is a workaround for me on my Arch machine. Seems like Cairo-Dock needs to be update to support the new librsvg version.’

Might the problem found it on the bug reports.

‘the bug appears only if the plugins package cairo-dock-plug-ins is installed.’
Perhals unistall it once?

There may also me something with the theme

run with the -m flag in matinence mode

For complete testing try and swtich to a default theme and see if the problem persists

This is what I was talking about earlier where it’s off the screen, see bottom right hand side:

I really dislike asking this, but how do I downgrade a package? I presumed I needed to uninstall it

sudo pacman -R librsvg

and then reinstall it via:

sudo pacman -S librsvg=2:2.42.4-1 

But all I get back is:

target not found: librsvg=2:2.42.4-1

I feel like such a noob, perhaps I should stay with Plank :sweat:

Trying maintenance mode now.

Sorry that was my fault librsvg is no longer in the aur

Sorry!

I know your problem are you scaled up? Try it at 100% once

1 Like

@OdiousImp Genius!
That is it, further… I should’ve thought about that because I have scaled it up, my res is 3000x2000 and it’s silly small on XFCE, hence why I usually go with Gnome, but I EndeavourOS’ home grown XFCE4 theme I quite like, thought I’d give it a try.

Doesn’t look like there’s a fix as of yet, so I’ll stick with Plank for the time being, it’s usable, I just want to periodically change up my system look a little to make it feel new.

That tool will help you downgrade a package.

2 Likes

Thank you, that’s much appreciated. The more I learn about Arch, the more comfortable I feel! :slightly_smiling_face:

You could try DockbarX


Sorry if this seems overwhelming!

Seemingly perfect!

Thank you, I’ll have a look at this, install it and let you know my experience! :slightly_smiling_face:

1 Like

As an XFCE guy - and on a hi-dpi (4K) screen - I doubt you need scaling anyway. Have you tried other hi-dpi tricks? Such as:

I’ve got to get this on the wiki here… :grin:

1 Like

Thank you! That’s such a good guide, I’ve bookmarked it. I’ll be looking out for it when it appears on here! :slight_smile: