Bug résolution ecran (Nvidia K620)

Bonjour à tous,
je suis nouvel utilisateur (enfin j’essaie…) de Endeavouros avec quelques connaissances assez limitées de Linux (utilisation de Manjaro précédemment). Je cherchais une distrib intermédiaire “un peu moins verte” sans tomber dans la complexité d’une Arch.

J’ai un problème de résolution d’écran depuis la première mise à jour juste après l’installation en mode Offline.
Lors de l’installation ainsi que lors du premier boot de l’installation terminée tout allait bien (1900x1200)
Suite à 1ère mise à jour je tourne en “mode dégradé” (1024x768).
Auriez-vous des pistes pour m’aider à résoudre ce problème ?

tu peux nous fournir

inxi -Fza --no-host

Le programme ChangeDisplayResolution aide-t-il à définir la résolution?

Bienvenu @cgz sur EndeavourOS.

As-tu installé le driver Nvidia en installant endeavouros OFFLINE ?

Ouvres le Terminal et tape plus haut ce que @Stephane demande, cela nous donnera les infos sur ta config écran pour t’aider.
As-tu essayé l’application Welcome pour configurer ton écran ?

Désolé de mon temps de réaction (pas d’accès à la machine régulièrement…)

@manuel : pas d’autre résolution dispo à part 1024x768

@Stephane + @FLVAL
la commande inxi me donne :

Graphics:  Device-1: NVIDIA GM107GL [Quadro K620] driver: nvidia v: 455.45.01 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:13bb 
           Display: server: X.org 1.20.10 driver: modesetting,vesa unloaded: fbdev 
           alternate: nouveau,nv tty: 100x30 
           Message: Unable to show advanced data. Required tool glxinfo missing.

J’image en lisant ça que le driver nvidia est bien installé.
Par contre j’ai vu une news sur le site Arch qui parle d’un problème du driver nvidia 455 avec le noyau 5.9 (https://www.archlinux.org/news/nvidia-45528-is-incompatible-with-linux-59/)
Peut-être que c’est l’origine de mon problème?
Si oui pas sûr de savoir quoi faire…

Sortie complète de inxi au cas où c’est utile :
http://ix.io/2HsO

lspci -vnn | grep -PA9 'VGA|Display|3D

Voici le résultat de lspci :

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107GL [Quadro K620] [10de:13bb] (rev a2) (prog-if 00 [VGA controller])
	Subsystem: NVIDIA Corporation Device [10de:1098]
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at de000000 (32-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at d0000000 (64-bit, prefetchable) [size=32M]
	I/O ports at e000 [size=128]
	Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia

Pourriez-vous montrer le résultat de ces commandes:

  pacman -Qs nvidia
  ls -l /etc/X11/xorg.conf.d
local/egl-wayland 1.1.5+2+g9c9c4c6-1
    EGLStream-based Wayland external platform
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/libxnvctrl 455.45.01-1
    NVIDIA NV-CONTROL X extension
local/nvidia 455.45.01-6
    NVIDIA drivers for linux
local/nvidia-installer-db 2.4.9-2
    Database for the script to setup nvidia drivers in EndeavourOS
local/nvidia-installer-dkms 3.3.8-2
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings 455.45.01-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 455.45.01-1
    NVIDIA drivers utilities
total 4
-rw-r--r-- 1 root root 266  8 déc.  20:12 00-keyboard.conf

Je ne suis pas sûr que cela aide, mais essayez d’utiliser nvidia-dkms à la place:

  sudo pacman -S nvidia-dkms linux-headers

Avez-vous regardé le lien vers Arch Wiki?

Merci, oui j’ai parcouru la doc mais pas hyper clair pour moi et avec plein de phrases du genre “si ça ne marche pas faites ceci” ou “si ça ne marche pas faites cela”…

Par contre je ne comprend pas que le driver utilisé soit bien le Nvidia propiétaire et que j’obtienne ceci :

[cgz@cgz-pc-home ~]$ nvidia-settings 

ERROR: Unable to load info from any available system

J’espère que ça aide: https://forums.developer.nvidia.com/t/archlinux-nvidia-settings-error-unable-to-load-info-from-any-available-system/111170

Êtes-vous sûr qu’il n’y a pas d’autres cartes graphiques (Intel) dans votre système?

C’est bon ça marche !!! Juste en tapant ça :

sudo nvidia-xconfig

J’avais pourtant lu dans la doc Arch

Xorg configuration

The proprietary NVIDIA graphics card driver does not need any Xorg server configuration file.

Pas d’explication du pourquoi dans mon cas il aura fallu faire cette manip pour forcer la création d’un fichier xorg.conf
Si un grand spécialiste a cette explication je suis preneur…

En tout cas merci de votre aide,
j’ai bien failli abandonner EOS juste après l’installation !

1 Like

Super que vous l’ayez fait fonctionner!
Et bienvenue à bord! :smile:

1 Like