Bug on upgraded pamac-aur (9.5.12-1 -> 10.0.0-1)

I got an a2x not found in updating pamac-aur 10.0.0-1
Then in installing asciidoc before update it was ok

sudo pacman -S asciidoc
5 Likes

Thank you for this tip! It solved my same problem.

2 Likes

i had the same issue here

https://forum.endeavouros.com/t/pamac-aur-question/10543/8

:+1:t3:

Sounds like a missing depends? (-> report to the AUR maintainer)

Didn’t have any problem updating pamac-aur-git.

1 Like

Me either, thats what I ended up installing & it pulled in the asciidoc file as well. :+1:t3:

I don’t have that installed? :thinking:

Edit: Is it a dependency of pamac-aur?

Yes. You have both man for pamac and pamac.conf which needs asciidoc as a make time dependency.

1 Like

Looks like pamac-aur maintainer does not build the package before upgrading it.

3 Likes

Won’t build at all for me:

../src/flatpak_interface.vala:41.3-41.35: warning: method `Pamac.FlatpakPlugin.trans_cancel' never used
                public abstract void trans_cancel (string sender);
                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation succeeded - 9 warning(s)
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'pamac-aur-10.0.0-1':
paru pamac-aur  19.15s user 5.02s system 52% cpu 46.415 total

Not especially bothered, was only trying to help @Christopher67 :smiley:

1 Like

You did yay -S pamac-aur-git worked and i noticed it also pulled in the file asciidoc. :+1:t3: :grinning:

But I am running pacman v6 alpha, so couldn’t test it. As stated above, but won’t use it anyways.

Thanks, this resolved the problem for me!

In the version 10.0.1-1 the dependencies have been corrected.

2 Likes

For me, i can’t seem to find the gui version of pamac. Has anyone experienced this? Yes i updated the repository

@TurkeyJohn

yay -S pamac-aur

↓
pamac-manager

or in the tray

pamac-tray