BTRFS, LUKS, SWAP and Wake from hibernation

I’ve always ran EOS on ext4 and I usually use a swap file instead of a partition. and had a readme of instructions to enable wake from hibernation as im on a Lenovo laptop and want to preserve as much battery. However these instructions do not work currently. I installed EOS with btrfs, with luks encryption and a swap partition, I’ve read many guides and the arch wiki and I cannot seem to understand how to get the system to wake from hibernate properly. The system just turns back on as if it was shutdown.


NAME             FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
├─nvme0n1p1      vfat   FAT32             14D6-2C22                            1021.3M     0% /boot/efi
├─nvme0n1p2      crypto 1                 d4ac25d3-2cfa-411e-8865-85b9ec4095ec                
│ └─luks-d4ac25d3-2cfa-411e-8865-85b9ec4095ec
│                btrfs        endeavouros bf094ebb-2b89-4b97-b745-f843a8e762f3  359.6G    61% /home
│                                                                                             /var/log
│                                                                                             /var/cache
│                                                                                             /
└─nvme0n1p3      crypto 1                 06355241-f281-4672-8ae3-811e85171d81                
                 swap   1     swap        c9c888bb-db16-4484-a37b-13fcac3e827f                [SWAP]

cat /proc/cmdline

BOOT_IMAGE=/@/boot/vmlinuz-linux root=UUID=bf094ebb-2b89-4b97-b745-f843a8e762f3 rw rootflags=subvol=@ quiet splash nowatchdog nvme_load=YES rd.luks.uuid=d4ac25d3-2cfa-411e-8865-85b9ec4095ec rd.luks.uuid=06355241-f281-4672-8ae3-811e85171d81 resume=/dev/mapper/luks-06355241-f281-4672-8ae3-811e85171d81 loglevel=3 nvidia-drm.modeset=1


# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=14D6-2C22                            /boot/efi      vfat    fmask=0137,dmask=0027 0 2
/dev/mapper/luks-d4ac25d3-2cfa-411e-8865-85b9ec4095ec /              btrfs   subvol=/@,noatime,compress=zstd 0 0
/dev/mapper/luks-d4ac25d3-2cfa-411e-8865-85b9ec4095ec /home          btrfs   subvol=/@home,noatime,compress=zstd 0 0
/dev/mapper/luks-d4ac25d3-2cfa-411e-8865-85b9ec4095ec /var/cache     btrfs   subvol=/@cache,noatime,compress=zstd 0 0
/dev/mapper/luks-d4ac25d3-2cfa-411e-8865-85b9ec4095ec /var/log       btrfs   subvol=/@log,noatime,compress=zstd 0 0
/dev/mapper/luks-06355241-f281-4672-8ae3-811e85171d81 swap           swap    defaults   0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0


[nosar77@KINGRALINTOP ~]$ blkid
/dev/mapper/luks-06355241-f281-4672-8ae3-811e85171d81: LABEL="swap" UUID="c9c888bb-db16-4484-a37b-13fcac3e827f" TYPE="swap"
/dev/nvme0n1p3: UUID="06355241-f281-4672-8ae3-811e85171d81" TYPE="crypto_LUKS" PARTUUID="218f18c3-9031-418e-aadb-ee38230cfad6"
/dev/nvme0n1p1: UUID="14D6-2C22" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI" PARTUUID="d5adc2d8-1b51-4939-8a6c-6cf0063b4149"
/dev/nvme0n1p2: UUID="d4ac25d3-2cfa-411e-8865-85b9ec4095ec" TYPE="crypto_LUKS" PARTLABEL="endeavouros" PARTUUID="80cd3709-6834-4731-b50e-dafc67c90c90"
/dev/mapper/luks-d4ac25d3-2cfa-411e-8865-85b9ec4095ec: LABEL="endeavouros" UUID="bf094ebb-2b89-4b97-b745-f843a8e762f3" UUID_SUB="bdd6c59a-09f5-4a95-b79d-59887107ee80" BLOCK_SIZE="4096" TYPE="btrfs"