BTRFS Install Issues

Has anyone had problems with BTRFS installs? I have tried it on multiple systems and have had nothing but problems. I tried the Endeavour installer, vanilla Arch a few different ways, and it even caused problems on my Nextcloud/UniFi server running Debian, which was faultless on extra.

My systems would become unresponsive for about 20 seconds at a time randomly. I thought it first it was the kernel, changed to lts and sill acted up. Then I thought it was related to KDE or Arch, but my server started acted up and it uses xfce and Debian. I also noticed that when the server became unresponsive the hard drive activity light was constantly on, like the disk was thrashing when I had a hhd and Windows Vista. All the machine run on SSD’s.

Now my data is corrupt on one of my laptops and my server. I tried to restore my server using timeshift but it tells me there is no snapshots like they were deleted.

I did a fresh extra install on my laptop two days ago and it is running flawlessly.

Works fine here.

In order to help you we would need to get some information from a system that wasn’t working well for you. If you have already replaced them all with ext4 it will be hard to figure out what the issue was.

Welcome to the forum!

Thanks.

I did redo the my main laptop, but I have another and the server is still “up,” well, not wiped completely yet. Corrupted to hell probably.

What do you need from it? I can get it later.

sudo btrfs subvolume list /
findmnt -t btrfs

Plus any relevant errors from journalctl would be a good start.

However if the filesystem is corrupt, it might be too late to get that info.

As a side note, snapshots alone won’t protect you from filesystem corruption because they live inside the filesystem.

1 Like

I don’t think my laptop is screwed like the server. It is “useable” between the hangs. When it does this the mouse is responsive, but it ranges from a single freezing app to the entire de.

I’ll upload the output in a bit for you. Thanks.

Here is the output for the Debian server:

Linux Putnam-Server 5.10.0-14-amd64 #1 SMP Debian 5.10.113-1 (2022-04-29) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri May 13 15:48:58 2022 from 10.9.0.3
       _,met$$$$$gg.          jeremiah@Putnam-Server
    ,g$$$$$$$$$$$$$$$P.       ----------------------
  ,g$$P"     """Y$$.".        OS: Debian GNU/Linux 11 (bullseye) x86_64
 ,$$P'              `$$$.     Kernel: 5.10.0-14-amd64
',$$P       ,ggs.     `$$b:   Uptime: 3 days, 14 hours, 21 mins
`d$$'     ,$P"'   .    $$$    Packages: 2716 (dpkg)
 $$P      d$'     ,    $$P    Shell: bash 5.1.4
 $$:      $$.   -    ,d$$'    Resolution: 1680x1050
 $$;      Y$b._   _,d$P'      Terminal: /dev/pts/2
 Y$$.    `.`"Y$$$$P"'         CPU: AMD A8-3870 APU (4) @ 3.000GHz
 `$$b      "-.__              GPU: AMD ATI Radeon HD 6550D
  `Y$$                        Memory: 1860MiB / 11449MiB
   `Y$$.
     `$$b.
       `Y$$b.
          `"Y$b._
              `"""

 Welcome to Incubator Computers

 jeremiah  Putnam-Server  ~  sudo btrfs subvolume list /
[sudo] password for jeremiah:
ID 2351 gen 109925 top level 5 path @home
ID 2352 gen 109925 top level 5 path @
ID 2353 gen 109167 top level 5 path timeshift-btrfs/snapshots/2022-05-10_01-35-07/@
ID 2354 gen 101928 top level 5 path timeshift-btrfs/snapshots/2022-05-10_01-35-07/@home
ID 2398 gen 109167 top level 5 path timeshift-btrfs/snapshots/2022-05-11_02-00-02/@
ID 2399 gen 104332 top level 5 path timeshift-btrfs/snapshots/2022-05-11_02-00-02/@home
ID 2481 gen 109167 top level 5 path timeshift-btrfs/snapshots/2022-05-12_02-00-01/@
ID 2482 gen 106666 top level 5 path timeshift-btrfs/snapshots/2022-05-12_02-00-01/@home
ID 2532 gen 109167 top level 5 path timeshift-btrfs/snapshots/2022-05-13_02-00-02/@
ID 2533 gen 108717 top level 5 path timeshift-btrfs/snapshots/2022-05-13_02-00-02/@home
ID 2555 gen 109686 top level 5 path timeshift-btrfs/snapshots/2022-05-13_13-00-01/@
ID 2556 gen 109687 top level 5 path timeshift-btrfs/snapshots/2022-05-13_13-00-01/@home
ID 2557 gen 109773 top level 5 path timeshift-btrfs/snapshots/2022-05-13_14-00-02/@
ID 2558 gen 109774 top level 5 path timeshift-btrfs/snapshots/2022-05-13_14-00-02/@home
ID 2559 gen 109856 top level 5 path timeshift-btrfs/snapshots/2022-05-13_15-00-01/@
ID 2560 gen 109857 top level 5 path timeshift-btrfs/snapshots/2022-05-13_15-00-01/@home

 jeremiah  Putnam-Server  ~  findmnt -t btrfs
TARGET                  SOURCE            FSTYPE OPTIONS
/                       /dev/sdd3[/@]     btrfs  rw,noatime,compress=zstd:3,ssd,space_cache,autodefrag,commit=120,subvolid=2352,subvol=/@
├─/run/timeshift/backup /dev/sdd3         btrfs  rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,commit=120,subvolid=5,subvol=/
└─/home                 /dev/sdd3[/@home] btrfs  rw,noatime,compress=zstd:3,ssd,space_cache,autodefrag,commit=120,subvolid=2351,subvol=/@home
1 Like

Welcome to EnOS’ community @jputnam!

Here is the output for the laptop:

                     ./o.                  jeremiah@LR-Laptop 
                   ./sssso-                ------------------ 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: Inspiron 5721 A08 
             `-/ossssssssssssso/.          Kernel: 5.15.37-1-lts 
           `-/+sssssssssssssssso+:`        Uptime: 30 secs 
         `-:/+sssssssssssssssssso+/.       Packages: 1366 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.1.16 
      .://+ssssssssssssssssssssssso++:     Resolution: 1600x900 
    .:///ossssssssssssssssssssssssso++:    Terminal: /dev/pts/1 
  `:////ssssssssssssssssssssssssssso+++.   CPU: Intel i7-3537U (4) @ 3.100GHz 
`-////+ssssssssssssssssssssssssssso++++-   GPU: Intel 3rd Gen Core processor Graphics Controller 
 `..-+oosssssssssssssssssssssssso+++++/`   Memory: 1518MiB / 3793MiB 
   ./++++++++++++++++++++++++++++++/:.
  `:::::::::::::::::::::::::------``                               
                                                                   


 Welcome to Incubator Computers

 jeremiah  LR-Laptop  ~  sudo btrfs subvolume list /
[sudo] password for jeremiah: 
ID 256 gen 100481 top level 5 path @
ID 257 gen 100481 top level 5 path @home
ID 258 gen 100481 top level 5 path @cache
ID 259 gen 100481 top level 5 path @log
ID 260 gen 27 top level 256 path var/lib/portables
ID 261 gen 28 top level 256 path var/lib/machines
ID 686 gen 100109 top level 5 path timeshift-btrfs/snapshots/2022-05-05_19-46-01/@
ID 687 gen 81562 top level 5 path timeshift-btrfs/snapshots/2022-05-05_19-46-01/@home
ID 688 gen 100109 top level 5 path timeshift-btrfs/snapshots/2022-05-05_21-00-01/@
ID 689 gen 81691 top level 5 path timeshift-btrfs/snapshots/2022-05-05_21-00-01/@home
ID 894 gen 100223 top level 5 path timeshift-btrfs/snapshots/2022-05-10_00-10-07/@
ID 895 gen 93046 top level 5 path timeshift-btrfs/snapshots/2022-05-10_00-10-07/@home
ID 896 gen 100223 top level 5 path timeshift-btrfs/snapshots/2022-05-10_00-10-35/@
ID 897 gen 93050 top level 5 path timeshift-btrfs/snapshots/2022-05-10_00-10-35/@home
ID 898 gen 100223 top level 5 path timeshift-btrfs/snapshots/2022-05-10_00-12-11/@
ID 899 gen 93055 top level 5 path timeshift-btrfs/snapshots/2022-05-10_00-12-11/@home
ID 900 gen 100223 top level 5 path timeshift-btrfs/snapshots/2022-05-10_00-24-34/@
ID 901 gen 93077 top level 5 path timeshift-btrfs/snapshots/2022-05-10_00-24-34/@home
ID 988 gen 100223 top level 5 path timeshift-btrfs/snapshots/2022-05-11_21-00-02/@
ID 989 gen 97467 top level 5 path timeshift-btrfs/snapshots/2022-05-11_21-00-02/@home
ID 1036 gen 100223 top level 5 path timeshift-btrfs/snapshots/2022-05-12_21-00-01/@
ID 1037 gen 100109 top level 5 path timeshift-btrfs/snapshots/2022-05-12_21-00-01/@home
ID 1040 gen 100339 top level 5 path timeshift-btrfs/snapshots/2022-05-12_23-00-01/@
ID 1041 gen 100341 top level 5 path timeshift-btrfs/snapshots/2022-05-12_23-00-01/@home
ID 1042 gen 100457 top level 5 path timeshift-btrfs/snapshots/2022-05-13_00-00-01/@
ID 1043 gen 100459 top level 5 path timeshift-btrfs/snapshots/2022-05-13_00-00-01/@home

 jeremiah  LR-Laptop  ~  findmnt -t btrfs
TARGET       SOURCE             FSTYPE OPTIONS
/            /dev/sda2[/@]      btrfs  rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=256,subvol=/@
├─/var/cache /dev/sda2[/@cache] btrfs  rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=258,subvol=/@cache
├─/var/log   /dev/sda2[/@log]   btrfs  rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=259,subvol=/@log
└─/home      /dev/sda2[/@home]  btrfs  rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=257,subvol=/@home

All look fine.
What about specific error messages, or problem on each one.
Please, remember that each system is a unique HW/SW combination, even if they look the same :wink: .

1 Like

Ok, I have quite a bit of experience with Linux, but not so much with troubleshooting. I guess I rely on timeshift way to much! Usually if I have a large problem I just do a restore or start from scratch the Windows troubleshooting way.

I think this might be my problem. I am using Timeshift with qGroups and I guess that is breaking my system:

https://forum.manjaro.org/t/freeze-issues-with-btrfs-and-timeshift/22005/18

Yes, it’s Manjaro, but it is what I found that is exactly like my issues. But if it wasn’t for Manjaro being so bad for me I wouldn’t be here!

Yes. Enabling quotas can definitely cause performance issues. I don’t think it is a hard requirement of timeshift though.

That was the problem. It’s fixed now. Thanks.

1 Like

You’re right, it isn’t really required, BUT …

… you probably introduced a new problem by fixing the IO-slow-downs when disabling btrfs quotas.

There’s an unfixed bug in Timeshift, where Timeshift fails to completely remove snapshots on the first try.
On this first try everything except the snapshot’s “info.json” file is actually deleted. This causes Timeshift to still list this (now unusable) snapshot! A second remove attempt then successfully removes the already deleted snapshot from the list.
This behaviour seriously messes up scheduling because actually deleted snapshots are still counted.

I posted this bug on timeshift’s GitHub pages quite some time ago (1) (2) but the issue still seems to be open.
There are some workarounds in the provided links -OR- you could just use snapper if you encounter this behavior.

3 Likes

Yeah, just found this bug and was about to post it before I saw your post. I just stopped using autosnap and just manually do backups every few days or when I do an update, which I do once a week. I think this will work for now. I used snapper in the past but I like Timeshift better since I have always used it since it was introduced into Mint.

Question about disabling quotas. When I use the command “sudo btrfs quota disable /” is it reclusive and disable all quotas or do I have to do it for each subvolume?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.