Btrfs Assistant 1.0 is coming, testers needed

I recently switched from BSPWM to Hyprland and now when trying to open BTRFS-Assistant I get the following error:

Authorization required, but no authorization protocol specified

qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

/usr/bin/btrfs-assistant: line 42:  8869 Aborted                 (core dumped) btrfs-assistant-bin ${params}

Before I trying installing some of the recommended platform plugins I wanted to check to see if anyone else has solved this issue?

wlroots-based environments really don’t like running Qt applications as root.

Support for each has to be added individually. I believe the support for sway is working now. Someone contributed support for hyprland recently but if you are running the latest version, I guess that isn’t working.

As a workaround, you can try running sudo -E btrfs-assistant-bin

2 Likes

That worked. Thanks @dalto for the information/education, quick response, and building an awesome app!

1 Like

Question? Why would I not have a “Btrfs Maintenence” Tab? everything else seems fine.

You need to install the package btrfsmaintenance

1 Like

Just a question: Yesterday I had to do with Manjaro on a computer and found out that there the Btrfs Assistant already comes installed in the live session and can be found in the Pamac in the repos. Why do we have to pull the Btrfs Assistant from the AUR here then? Everything grumbles here on Manjaro and turns up his nose when this name is mentioned, but obviously they are in some things further than we are.

Because it isn’t in the Arch repos?

It is also in the Fedora repos.

It’s also in the Chaotic-AUR.

pacman -Ss btrfs-assistant
chaotic-aur/btrfs-assistant 1.8-1 [installed]
    An application for managing BTRFS subvolumes and Snapper snapshots
chaotic-aur/btrfs-assistant-git 1.8.r0.g3de16cb-1
    An application for managing BTRFS subvolumes and Snapper snapshots

It is very easy to set up:

1 Like