Btrfs Assistant 1.0 is coming, testers needed

A number of things :wink:

  • The <> means “something goes here”. They should be omitted from the command
  • You can’t have a space after the comma.
  • @ isn’t a snapshot. You need to tell it which snapshot you want to restore.

Basically, you just copy and paste one of those strings from your output. They are already formatted correctly.

no luck :frowning:

I pasted sudo btrfs-assistant -r @58Sun Jun 19 20:00:01 2022single@/.snapshots/58/snapshot,cda3e3f6-4450-455e-9fd8-ae48d27675a8

try this:

sudo btrfs-assistant -r @/.snapshots/58/snapshot,cda3e3f6-4450-455e-9fd8-ae48d27675a8


  • subvolume: @/.snapshots/58/snapshot
  • UUID: cda3e3f6-4450-455e-9fd8-ae48d27675a8

Try this - sudo btrfs-assistant -r @/.snapshots/58/snapshot,cda3e3f6-4450-455e-9fd8-ae48d27675a8

1 Like


I had date in there. silly me.

thank you!

1 Like

Try using different btrfs commands as given btrfs man pages to get more familiar with different operations that are performed by btrfs tools

1 Like

last question - what is the “snapper boot enabled” in the menu of the BTRFS-Assistant app?

Appreciate all the help!

That enables the systemd service that takes snapshots on boot.

1 Like

Thank you. That explains it.

1 Like

Hi can confirm also works on manjaro


Welcoming @stormschip to :enos_flag: Enjoy.

@dalto Hi Dalto, I had a quick question.

I’ve chosen to retain 3 snapshots but I don’t think its working. Here is a list of snapshots and my settings.

How else can I limit the number of snapshots saved?

When did you set that to 3?

Just within the app when I installed it.

You can see 3 snapshots in the 2nd screenshot

Or is that setting just for timeline ?

Can you share the output of systemctl list-timers

It looks like the timer hasn’t run but is about to run any minute.

Check in 2 minutes and see if it cleans up the snapshots

1 Like

ahha it actually worked. don’t know what happened. but I see 5 in the list. I was expecting 3

One of them is a timeline snapshot from when you had those enabled. You will probably have to delete that one manually.

The other ones are probably too new. There is a minimum time in the config.

That being said, retaining 3 number snapshots makes very little sense.

For one thing, recent snapshots take up almost no space so aggressively pruning them has very little value.

Even if that wasn’t the case snap-pac takes snapshots before and after each pacman operation. Saving 3 means you have the one before and after the most recent operation and the one after the prior operation. I would recommend saving at least 6

1 Like

thanks for the explanation Dalto. makes sense. I will update to 6.

you are right about timeline snapshot. I had it enabled and now its disabled.


1 Like