Bssid =0:00:00:00

Hi, can’t connect to WiFi . Restarted, resetting and nothing helped. BSSID = 0;00:00:00:00 . Any help suggestions???

Did you checked this Post ?

https://forum.endeavouros.com/t/workaround-how-to-fix-connection-bug-within-networkmanager-1-22-2

Yes, but don’t resolve the problem

Give the answer from :

rfkill list

: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
soft blocked? :thinking:

Do a :

rfkill unblock all

then show me :

rfkill list

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
dont work

now that your card is correctly activated check the wifi networks available :

iw wlan0 scan

Is correct activated, because I see my WiFi , but don’t connect. I see a loading circle :o: in panel tray

So it’s already better, do You use WEP or WPA key ?

wpa key mean my wifi password? yes

You never give any password here, you keep that for you…
Check your device driver before if your wifi is on pci use :

lspci -k

if usb use :

lsusb -v

07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)
Subsystem: Hewlett-Packard Company RTL810xE PCI Express Fast Ethernet controller
Kernel driver in use: r8169
0d:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] (rev 83)
Subsystem: Hewlett-Packard Company Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile]
Kernel driver in use: radeon
13:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)
Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n
Kernel driver in use: wl

You see Kernel driver in use: wl for Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n
To see if a wireless interface is created, do this below and give the result :

ip link

You could check here about your Broadcom :

https://wiki.archlinux.org/index.php/Broadcom_wireless

tiger@tiger-pc ~]$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether b0:5a:da:99:d6:a9 brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state DORMANT mode DORMANT group default qlen 1000
link/ether 42:84:86:3f:0b:4b brd ff:ff:ff:ff:ff:ff

what mean Dormant mode??

What is important is to see that your wifi is setup UP
The DORMANT mode is about save power mode that could reduce some channels to be received.
Do you know which channel you use on your provider setup ?

on browser setup i have channel on auto

could you send me a screenshot of your panel tray ?
It seems driver of your wifi card is ok, all is UP wihtout error, so we need see the WPA stuff…
Are you sure about your WPA key ? you have different type of WPA…


no, wpa is the same , never changed

i put gnome DE, this wifi problem is old…before 27-28 december , and gnome was the only one who works to conect, but now, dont want…and i dont know why, im not so newbie on linux :roll_eyes:

Weird, I know there is problem with IPV4 these last days but the post from @FredBezies issue on 1.22 resolved it. I used wired so couldn’t test as well for wifi.

You could check for IPV4 with :

ip -4 addr show

Did you try to disable the wireless card’s [power saving] ?
https://wiki.archlinux.org/index.php/Network_configuration/Wireless#Power_saving