Broken audio

I’ve installed Endeavour XFCE earlier today (so using Pipewire, as the system was not modified too much), and though it worked fine most of the day, the audio suddenly decided to break itself just now. Several system sounds just do not play at all, and while listening to music, it sounds distorted and like it’s missing half of the sound notes - for example, only the background melody is audible, while the vocals and lyrics simply do not play.

I went to the Arch Wiki for help, and it told me to edit /etc/pipewire/pipewire.conf, except no such file exists. I panicked and tried to switch to pulseaudio, but the issue is still present, plus installing pipewire removed pulsewire (or whatever else is the package that bridges the two together that comes with EOS) and I can no longer remove pulseaudio due to it webbing itself onto essential packages. Needless to say, to say that I am frustrated would be an understatement.

This seems to have happened out of nowhere, but I do recall I was halfway through installing Timeshift via Yay (from the AUR) when I noticed the audio issue. I don’t know if that played a part on it.

Could you post the link for your hardware and paste the output of the audio command here which is the 2nd one.

inxi -Faz --no-host | eos-sendlog
inxi -Aa

Also can you explain system sounds? I don’t have system sounds set up for anything.
What exactly did you do to install pipewire that you say removed pulse audio?

So if I understand, you are currently using pulseaudio, not pipewire?
Can you show us the output of;
pactl info

Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 6
Tile Size: 65472
User Name: evelyn
Host Name: pondwave
Server Name: pulseaudio
Server Version: 15.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_0a_00.4.analog-stereo
Default Source: alsa_input.pci-0000_0a_00.4.analog-stereo
Cookie: d3ed:493a

My suggestion would be to try installing the pipewire package (it should prompt you about a conflict with pulseaudio, confirm to replace it), and then additionally install pipewire-pulse.

Seems like the issue was somehow fixed by cranking the volume to 150% and then lowering it. I have no idea why, and frankly I’m not happy with this hackish workaround and want to know what’s wrong. (Also, if it’s not too much to ask, is it possible to make it so I can move the volume past 100% with the volume traybar icon using my mousewheel? The mousewheel lets me change my volume easily anywhere from 0% to 100%, but I always have to click on it to raise it past 100%, which I find a bit annoying.

inxi -Faz --no host | eos-sendlog:
https://clbin.com/TY8l9

inxi -Aa:

Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Tul driver: snd_hda_intel v: kernel bus-ID: 08:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0a:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.7-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.41 running: no

Oh, I meant stuff like Discord and Matrix/Element notifications, which for the most part weren’t making any sounds at all.

Sorry, that was a typo; I installed pulseaudio, and that removed pipewire. I simply did “sudo pacman -S pulseaudio”, and it said there was a conflict with a pipewire package that had to be removed.

It was a typo on my post, sorry; I initially had pipewire, then installed pulseaudio to see if the issue would be fixed, and that removed pipewire. Pipewire is still installed on my system (I can’t remove it because core systems depend on it), so I’m not sure if trying to install it again would work. In that case, would I just have to install pipewire-pulse to remove pulseaudio? Either way, I can’t remove pulseaudio since it says several core systems depend on it.

You can tell if pipewire is installed and running correctly because your pactl info should say;

...
Server Name: PulseAudio (on PipeWire 0.3.x)
...

If pipewire and pulseaudio are somehow both on the system, that will cause issues. The trick to avoid breaking dependencies is to replace one with the other. It sounds like you did do this, so I’m not sure what went wrong.

PS: this documentation might be helpful;

Not much of the documentation helped. Setting the volume to 150% fixed it for a bit, even after rebooting, but while playing, the audio randomly broke itself yet again. I have no idea what to do.

EDIT: Now I have no audio at all. Honestly tempted to give up entirely on EndeavourOS.

Don’t give up. Reinstall pipwire with this.

sudo pacman -S pipewire pipewire-pulse --needed

Edit: There were a number of updates to pipewire just now.

I did that, and it still doesn’t work. I also did a full -Syu and rebooted, and the audio is still broken.

I have zero issues with audio. All you can do is try to go back to pulse audio.

I’m an absolute idiot.

The issue wasn’t with PulseAudio or Pipewire. It was because my headset’s jack was loose. I unplugged and re-plugged it, and the audio’s working normally again on both PulseAudio and Pipewire.

Thank you for dealing with my idiocy and trying to help, though. ^-^’ Now, uh, since I’m probably going to stick with Pipewire, is it safe for me to delete Pulse packages? iirc, some of them are still used as dependencies.

1 Like

The command i gave to install pipe wire should be fine. It will remove the pulse and replace it with the appropriate package. The audio should look like this.

[ricklinux@eos-kde ~]$ inxi -Aa
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 2d:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 2f:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.8-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
[ricklinux@eos-kde ~]$ 
2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.