Broadcom wifi chip not connecting or not showing with new 5.10.3 kernel. Module loaded is bcma.

1 Like

I was able to fix it by uninstalling broadcom-wl-dkms and installing broadcom-wl. Once it was working i reinstalled the broadcom-wl-dkms version. It just needed a kick to get it working! :laughing:


Just an update. I found that after i disconnected the ethernet and happened to reboot the wifi was lost again. I reverted to the broadcom-wl and it seems to stay. Did some tests unplugging the ethernet & restarting seems to stay working now.

1 Like

post if your computer starts freezing/locking

I did the same steps now and I’ll see the freezing/locking stops

Moderation Note: Moved from Just in case anyone is experiencing issues with their WiFi on 5.10.3 so all the potential solutions would be in the pinned post.

Morning all!

A day or so ago I did a system update that installed the 5.10.3 Linux Kernel that broke my Broadcom WIFI drivers (no connectivity). So I had to run my 50ft Ethernet cable across the room for fixing (I am stubborn).

Turns out the issue was that the community repo Broadcom-WL driver was not updated (installed, but not working). I found out that you can enable the community-testing repo and install the newer broadcom package for the time being and then switch over to the regular repo should it become available in the future which looks like already happened.

This is just out here for a future solution should anyone else encounter it - I am sure there is a better way like rolling back the updates but I couldn’t figure it out (still new) and also tried using my LTS kernel with no luck.

Driver in question:

I enabled the community-testing repo and edited the pacman.conf file located in ./etc to be search only so I can pick and choose.

Find/Locate and edit the pacman.conf file using Vi or your favorite editor to uncomment “[community-testing] include =/etc/pacman.d/mirrorlist” and add “Usage = Sync Search” below it.

It should look like this:
[community-testing] Include = /etc/pacman.d/mirrorlist
Usage = Sync Search

Re-sync using
pacman -Sy

Use to install the alternate driver.
pacman -S community-testing/broadcom-wl-dkms


The only problem i have with this solution is for some users enabling the testing repo is not a good idea. It may create a lot of problems.

Edit: I have found that the dkms version wasn’t working and i reverted to the broadcom-wl and it is working for me on more than 4 machines.

@ricklinux that is what I read as well as dependencies can get ugly, but it should not install anything setting the Usage to Sync Search based on my reading. This then allows you to install only the package you want and it will maintain that package. I did notice that when the new broadcom driver was pushed to “community” it synced over automatically and is no longer listing as community-testing.

I am by no means and expert and maybe I misinterpreted what I read - so when I failed to revert the update I went ahead with the above solution. Just an option

Maybe i didn’t see that part. I’m no expert on it either. I was just worried about it bringing in other updates from testing.

1 Like

An alternative way to install this from testing without adding the repo would be to just install it directly with pacman -U. Like this:

sudo pacman -U

This way you get the driver from testing without having to add the repo.


For sure, I was scared I was going to bork my install - but it really is true when they say the linux community has a wealth of information and so long as you have the CLI, anything is possible! :slight_smile:


See - I learn something new everyday - did not know I could do that =)

1 Like

I’m going to try this one as i did have the dkms version before on all the systems.

1 Like

Just be careful if you try it with a package that has lots of dependencies. You could get in a situation where the package needs other dependent packages to be at a certain version which is only in testing.


Don’t forget you can connect your phone to your USB have your phone connected via wifi, and then use wired tethering. . . Just in case you don’t want to run a 50ft cable again next time.

1 Like

Just make sure your plan has sufficient data for this or you may end up with a surprise phone bill. :astonished:

EDIT: As @fbodymechanic points out, it shouldn’t use data if your phone is connected to wifi.

1 Like


Both points taken!


Again, I learn something new, thank you for pointing this out!

If your phone is connected via wifi. . . it shouldn’t matter? I guess I never checked. I have unlimited data. But I thought Phone + Wifi + tethering = ok?

1 Like

Good point. Just make sure your wifi doesn’t lose connection and the phone fails over to cellular.

1 Like

Connect your phone at your own risk. Or run the cable. I’m certainly no phone guru, so I don’t know.

Everyday I dream for the day I win the lottery and can go out and buy a nice flip phone that only does calls and text messages. I hate this stupid phone.