Brightness buttons not affecting screen brightness

The brightness keys result in the little brightness panel appearing on screen (see image) but the brightness doesn’t alter. I am running Plasma on a ThinkPad X395. I dual boot with Kubuntu and the brightness works okay. I’ve tried changing the brightness in Settings > Energy Saving > On AC but that doesn’t change anything either.

Any suggestions for possible solutions would be lovely! :slight_smile: :grinning:

Don’t know the answer myself, but I tweaked the title of your question to describe your issue more closely. Hope this will help others understand your issue better so they can help you out.

1 Like

I’d suggest trying xbacklight and see what it does.

I had this issue as well… if I recall correctly, it required changing/setting the kernel command line option for acpi_backlight in the grub.cfg file.

Try video, vendor, or native to see if one of those work first. There also may be vendor-specific drivers that you need to install… I didn’t for my case.

1 Like

Thanks for your suggestions, I did do a bit of tinkering and never managed to solve the problem. I had reason to do a clean install recently and the brightness keys worked immediately. Thanks to everyone who commented with their suggestions. I know don’t have to watch films in the dark at max brightness, my eyes are saved! :smiley: