Both wifi and ethernet show up as connected but can't reach any website

Hello, I started using endeavouros on my main pc a few months ago and I decided to install it on my school laptop last week. Both wifi and ethernet worked at the start. I installed a CA Certificate required to connecting to the internet from the school wifi and I installed the protonvpn-cli package to use on the school wifi.

After some updates connecting to any network via wifi or ethernet and opening any website on firefox started to give me this error:

We can't connect to the server at

Pinging a website gives me this error:

ping: Temporary failure in name resolution 

For some reason connecting to protonvpn using the saved vpn connection made everything work normally but now the vpn no longer works and asks for a password when attempting to connect.
Network manager shows up as connected and the connections i tested work when connecting through my phone.

I think I messed something up when installing the CA Certificate and I don’t know how to reset everything network related. I’ll try to provide any logs needed via my phone. Thanks.

Here’s the inxi output:

  Kernel: 5.17.4-arch1-1 arch: x86_64 bits: 64 Desktop: Xfce v: 4.16.0
    Distro: EndeavourOS
  Type: Laptop System: Hewlett-Packard product: HP Notebook
    v: Type1ProductConfigId serial: <superuser required>
  Mobo: Hewlett-Packard model: 80C2 v: 96.02 serial: <superuser required>
    UEFI: Insyde v: F.02 date: 03/24/2015
  ID-1: BAT1 charge: 8.4 Wh (24.9%) condition: 33.8/41.4 Wh (81.6%)
    volts: 14.5 min: 14.8
  Info: dual core model: Intel Core i5-5200U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1728 min/max: 500/2700 cores: 1: 2196 2: 1121 3: 1403
    4: 2195
  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
    520 Mobile]
    driver: radeon v: kernel
  Device-3: Chicony HP Truevision HD type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1 driver: X:
    loaded: intel,radeon unloaded: modesetting gpu: i915
    resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2)
    v: 4.6 Mesa 22.0.2
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
  Device-2: Intel Wildcat Point-LP High Definition Audio
    driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.17.4-arch1-1 running: yes
  Sound Server-2: PipeWire v: 0.3.50 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: 30:8d:99:c4:5b:74
  Device-2: Broadcom BCM43142 802.11b/g/n driver: wl
  IF: wlan0 state: dormant mac: 42:88:21:75:d4:05
  IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
    mac: 12:e5:db:2b:f8:bb
  Device-1: Broadcom BCM43142A0 Bluetooth 4.0 type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 465.76 GiB used: 27.74 GiB (6.0%)
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680
    size: 465.76 GiB
  ID-1: / size: 81.78 GiB used: 27.71 GiB (33.9%) fs: ext4 dev: /dev/sda6
  ID-2: /boot/efi size: 96 MiB used: 25.2 MiB (26.3%) fs: vfat
    dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: 27.8 C pch: 31.0 C mobo: N/A gpu: radeon
    temp: 31.0 C
  Fan Speeds (RPM): N/A
  Processes: 179 Uptime: 1h 40m Memory: 3.75 GiB used: 1.23 GiB (32.9%)
  Shell: Bash inxi: 3.3.15

Hi @deniztunc welcome to the EOS community,

The error was resolved by turning off the kill switch in Proton VPN. Apparently this is caused by the IPV6 leak interface getting left in place if the system is shut down while the VPN is connected with kill switch on. This will persist until the kill switch is turned off or the VPN disconnected and reconnected. This is a known bug that should be addressed at some point.


protonvpn-cli ks --disable

Oh thanks! I wasn’t aware of this feature at all. I checked it right now and it works now. One small thing that I had to change in the command though was the --disable into --off.
Thanks again!


Welcome to EnOS’ forum @deniztunc!


1 Like

Hello @deniztunc and welcome aboard :enos:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.