Borked config in /home, can't open gnome settings


I have a strange issue with gnome atm and can’t figure out what’s going on. Here’s what happend:

Today I tried some tiling window managers, namely hypr, sway and swayfx. I installed all with yay, except for sway for which I used the install script for the sway community edition of EndeavourOS.

edit. Here’s the script I used:, and the configs it copied: I don’t see anything in there which would result in this behaviour.

After I was done with testing I decided to log in back to Gnome.
Everything seemed fine, expect for some reason gnome-control-center would not start. I tried reinstalling, rebooting, everything but finally gave up and reinstalled EndeavourOS itself.

After booting everything was fine again so I decided to mount my /home on another partition. All my settings were back but again - I just can’t start gnome settings. Some more information:

  • I tried a full reset of gnome with dconf reset -f /org/gnome/, which wiped all my themes etc just fine but still, no gnome settings
  • Trying to launch gnome-control-center with a terminal doesn’t work either, I don’t even get an error message
  • Everything else works fine. Nautilus, gnome extensions manager, gnome-text-editor, the calculator…
  • When launching settings with Activities or by right-clicking on my desktop I get a spinner for a while

Given that my issue reappeared as soon as I mounted my /home I suspect some borked configs are the culprit.

I would appreciate any help as I do not want to wipe my /home - nor do I want to switch to KDE. Please let me now if you need more information, and if I don’t answer within an hour I probably went to bed. It’s already 1am.

If you run from a terminal does it give any useful messages?

Nothing, no error or any indication that something went wrong.

~$: gnome-control-center


top > o > command:gnome-control-center doesn’t show anything, too.

a couple thoughts…

Can it launch from the terminal with sudo?

Rename .local and .cache to say .local_OLD and .cache_OLD and see if it launches and rebuilds those folders. (If not, put back your original .local and .cache).

Sudo gives me the same output:

syrma@syrma56x-iota:~$ sudo gnome-control-center
[sudo] password for syrma:

I tried renaming .local first, rebooted - nothing. Tried .cache afterwards and again, nothing. This is so weird. Both folders were rebuild. What happens if I rename .config, will that f- something up?

edit. Just found this file in my /home


export XDG_SESSION_TYPE=wayland

Success! I changed XDG_CURRENT_DESKTOP=sway to XDG_CURRENT_DESKTOP=GNOME, rebooted and now Settings starts again.

Lesson learned: A backup of / is not enough :smiley: Thank you for your help, I appreciate it!

1 Like

Glad you found it :). You should probably put your original .cache and .local files back the way they were just in case.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.