Bootup sequence broken

I upgraded awhile back and my regular boot started to fail. I used failsafe and it was fine. Now, I upgraded again, and failsafe is broken too.

I get through grub fine, drives start mounting, system is activating, and it spits me into emergency mode and tells me to use journalctl -xb

I do this with | grep fail and such and get nothing that looks all that interesting. I first see a mention of /usr/bin/plymouth, which I don’t even think i was using. I install it after loading partition and chrooting from liveusb, but that doesn’t help at all.

I reinstall grub/etc. from livecd, not that I expected this to work because grub itself was fine, but it didn’t fix

I look through journal - xb a bit more, the only thing else I see is mention of swap failing because of a swap partition it can’t activate. This doesn’t even appear in /etc/fstab so I’m not sure why it’s even trying to activate any swap. I did a grep -r /etc for x2ddiskseq-4 which was what it mentioned in the error but I couldn’t even find which file was trying to activate swap, and none of the job names from systemctl mentioned it.

So at this point I just want to try disabling swap to see if that will get me booting but I don’t know how to do that.

I think maybe when I reinstalled windows is when my swap partition was moved from 11 to 9?

I can see I have a swap on nvme0n1p9 but the log mentions it expects nvme0n1p11

I was able to see something in cat boot.log that told me to go to systemctl to ask about this and I tried to disable x2ddiskseq-4 there but it won’t let me disable it because of something I don’t understand about how it’s tied into other things.

Finally figured this one out

The key command was systemctl --type swap

This let me know exactly what to do, and chatgpt helped me know to mask this instead of disable it since I was not understanding that

Even after switching swap over to partition 9 in fstab it still wasn’t working, which means that the swap is probably messed up somehow, probably due to that windows installation breaking it somehow.

I was also able to figure out how to fix swap. My partitions had been labeled incorrectly, fixed that with cfdisk, and then used mkswap to fix the partition itself.

1 Like

using partition numbers is fragile, use UUIDs instead.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.