Booting from USB on 2009 macbook

Hey all

I have an old 2009 macbook, on which I’m trying to install EndeavourOS XFCE on it.

I’ve used Gparted to shrink the original OSX hdd, and it booted fine - but when I create my boot media with EndeavourOS using gparted and plug it into the macbook, booting holding down alt to select boot media, nothing shows up (apart from machintosh HD and recovery.)

Anyone know anything I should be aware of?

Do you need some kernel parameter such as nomodeset?

https://wiki.archlinux.org/index.php/MacBook5,2_(early-mid_2009)

I got the USB to show up, but getting the error


Tried both normal and none free. Will try to read your link!

This looks like a faulty image or broken USB stick, not a graphic card driver error.
It says it can’t locate the USB stick at the end.

Try re-download the image and re-write it to the stick, preferably a different stick.
Also maybe just try to plug the stick in a different USB port first?

2 Likes

I have installed EndeavourOS on two old (older) Macs without issues.

Usually, just after powering up hardware and at the Apple chime, I hold down the ALT/OPT key for a while and upon release I see two drives. A EFI Boot with a HDD icon and an EFI Boot drive with an yellow USB icon. Select the drive with the USB icon and you should be able to boot off the drive and proceed to testing or installation. Works for me all the time. Good luck, user!

What? Me Worry! I know what I know because I know it …

2 Likes

I have an 08 MacBook someone gave me a few months ago and I couldn’t get Endeavour on it. Turns out it was i686 architecture and no longer supported by Arch. I ended up putting MX Linux on it since they are one of the few who still support 32 bit.

You could be running into the same issue.i couldn’t even get the MacBook to acknowledge the USB

1 Like

Thanks for the info on the '08 MacBook/i686 architecture. Good to know! As stated I successfully installed EOS on all computers, easily and they are functional. The only issued I am currently experiencing is with the MacBook 2010. The laptop continues, after several attempts at a resolution, to freeze after idling for some time. It was suggested to run an LTS kernel which I am doing. It seem to have extended the time before freezing. Continuing to seek a resolution. No success yet.

It was a suggestion for the OP as they are the one having the issue :wink:

BUT, if you’re having an issue with an install, please post up some logs on your computer and start a thread. We’d love to help you. It’s much easier to compartmentalize and help per thread. That way when/if a solution comes up, we can mark it solved and will become searchable if others have the same issue.