Boot Up Issue - USB Ports Disabled

My USB ports seem to be disabled during boot-up making it impossible to access the UEFI menu, because pressing the DEL key gets me no response.

My keyboard backlight is also always off when booting up. It finally turns on only when the display manager is loaded. This is how I tell that the USB ports are disabled in the boot-up process.

How do I enable my USB ports during boot-up?

Try enabling USB legacy mode in bios, and try another port. On older machines the USB3 ports have a special implementation (them being new for those times) and initialize later during the POST process. So also try USB2 ports on the machine if present.

1 Like

Also keep in mind that it could be the keyboard. I have several laptops which behave differently with different keyboards - some combinations work at POST, some do not.

1 Like


I’ve tried with different keyboards…all the same

If I can’t access my motherboard UEFI menu, how do I access the legacy bios mode?

I’ve tried all of my USB ports including USB3 and USB2 ports, and with different keyboards too. None worked.

Do you have any OS installed on your machine that you can boot into at the moment?
If yes:
Once you boot into an OS you can reboot straight to UEFI: In Windows you have advanced startup options hidden somewhere in settings (google should help there, as I can’t remember the steps), in Linux you type systemctl reboot --firmware-setup to boot into UEFI
If not, tell us more about the machine.

Unfortunately, I don’t have another OS installed.

My motherboard is AS Rock Z87E-ITX. UEFI access keys are either F2 or DEL.

My system:

  • Endeavour OS version 3.12 something (I think) with Xfce
  • Grub 2.04
  • Linux 5.7.12-arch1-1
1 Like

From your motherboard manufactures forum:

"Given your mouse and keyboard refuse to work, you will need to clear the BIOS/CMOS.

This is the procedure to do that:

The PC must be shutdown/ shut off. The PSU power switch in the Off position. AC power removed from the PSU, unplug the PSU.

Open up the PC case. The Clear CMOS jumper is on the lower right side of the board, not far above the screw in the lower right corner. CLRCMOS1 is written on the board by the jumper.

Remove the jumper from the center and pin on the left, and move it over one pin so it is on the center pin and pin on the right side. Leave it in that position for a minute. You can also remove the battery from the board temporarily for a complete BIOS clear, usually not needed.

After the minute, put the jumper back on the center and left pin, the normal position. Connect the battery again if it was removed.

The procedure is complete. Put the PC back together, connect power to the PSU, and try to start it.

If you’ve been using USB 3.0 ports for the mouse and keyboard, don’t bother. Use the USB 2.0 ports, since all keyboards transmit data at less than USB 1.1 rates.

If this still does not work, the BIOS was corrupted for some reason, and we’ll need to see how we can update the BIOS without a working keyboard. Confused"

On page 11 of your manual there is a picture as to where the jumper is. I have circled it for you…


oh wow… thank you… haiz… truly not hoping something like this

Now that you mentioned it, I think my BIOS could be corrupted because quite often, my PC would reboot straight after I shut it down from the OS, and I just replaced the battery a few months ago.

Wait you have EOS installed? can you not boot into it? Doesn’t have to boot into a graphical environment, just a console would be enough. Then you could login and type systemctl reboot --firmware-setup

“Cannot indicate to EFI to boot into setup mode: Firmware does not support boot into firmware.”

Shoot… my system is too old I guess

It only works if the OS itself was booted in EFI mode. I guess it’s running in legacy BIOS mode.

I see. So, no way of accessing my bios without resetting something on my motherboard?

Simpler (and probably wont work :smiley: ) take the motherboard battery out again, leave for a while, hold the power button in for 10 seconds or more, then turn it on and repeatedly hit the key to enter the bios.