Boot time increased after motherboard upgrade from Gigabyte x299 UD4 Pro to Designare EX

OK, I just moved to a new motherboard & am getting a startup problem. I have looked thru logs, disabled watchdog timers, tried the fixes for random number generation & updated the bios to the current version, all with no luck. On boot the system “sticks” at “loading inital ram disk” for about 30 sec & then I see welcome to EndeavourOS & boot goes normally. As above, I have tried:

  1. Grepped thru the logs looking for anything that could be interesting-problem is before log start (I know its a very early boot issue).
  2. Looked thru the forum & disabled watchdog timers
  3. Applied random-number generation fixes
  4. Searched Google & looked at Arch Wiki
  5. Updated the BIOS to latest version
  6. Played with MBR vs GPT–UEFI-created a new install on a spare SSD that is UEFI-no change -boots just the same.
  7. Tried various compression versions in the mkinitcpio.conf–setteled on lz4–no real change.

Both Motherboards are made by Gigabyte–I had a x299-UD4Pro & updated to a x299 Designare EX–Same CPU I7-9800X , same 32G ram & same NVMe main drive - same SSD extra drives. The only change to the system was the motherboard swap.

Yes, its only at most 30 sec, but with the UD4 board, I could boot to login screen in about 15 sec—now its about 45 sec.

What have I missed???

Have you tried rebuilding your initramfs’s with sudo mkinitcpio -P?

And checked the UUID of the drives hasn’t changed?

1 Like

Try to rebuild grub or to boot with ‘tsc=unstable’ kernel parameter

Yes-several times–after changing the compression types.

No change to the UUID–Fstab is unchanged.

That sounds like a good idea.

So you ran sudo blkid and compared?

I normally fire up gparted & look at info for the partitions–but I did sudo blkid & everything matches that way also.

As for tsc=unstable, that had no change. I rebuilt grub after changing & then did a sudo mkinitcpio -P for grins afterward.

Thank You everyone, for the ideas so far…that’s a couple more than I had thought of :slight_smile:

OK–more info—I remember that there was an update to mkinitcpio.conf a while back & I normally rename the old file with a .bak so I can reference it in case of problems with the new file. In any case, the module loading had changed between the 2 files, so I changed the new file back to the old style, then rebuilt with sudo mkinitcpio -P. Rebooted–no change. I remove “quiet” so I can watch boot & it looks like the problem is very early in boot…Anyone know about initial ramdisk creation?

1 Like

What is your Graphics card?
inxi -Ga

It sounds like something in your initrd is waiting for a timeout and then continuing.

Are you using luks?

What does your mkinitcpio.conf look like? Have you customized that at all out side of the compression change?

Dual Nvidia 1070GTX

No. not using luks…as far as changes to mkinitcpio.conf—I reverted the changes made to module loading order that were changed with the new version. No change either way (new or old versions). This is something not showing in the logs–I can clearly see the (udev) module loading–nothing sooner.

Also, this is something that seems to be related to this motherboard…my “old” UD4Pro loaded the ram disk in very short time–I don’t know why the Designare EX would delay so much loading the same stuff…

I see this in the manual.

BIOS Setup- 61 -& SATA Support Last Boot HDD Only Except for the previous boot drive, all SATA devices are disabled before the OS boot process completes. All SATA devices are functional in the operating system and during the POST. (Default) This item is configurable only when Fast Boot is set to Enabled or Ultra Fast.

Edit: Also

BIOS Setup- 62 -& Storage Boot Option Control Allows you to select whether to enable the UEFI or legacy option ROM for the storage device controller.eDo not launch Disables option ROM. UEFI Enables UEFI option ROM only. (Default) Legacy Enables legacy option ROM only. This item is configurable only when CSM Support is set to Enabled.& Other PCI devices Allows you to select whether to enable the UEFI or Legacy option ROM for the PCI device controller other than the LAN, storage device, and graphics controllers. Do not launch Disables option ROM. UEFI Enables UEFI option ROM only. (Default) Legacy Enables legacy option ROM only. This item is configurable only when CSM Support is set to Enabled.

Edit: Also do you have Sata mode set as AHCI?

Yes–all are set as AHCI. 61 looks interesting. I do not have Fast Boot set. Will look into it. Thanks!

Well–set both fast boot & ultra fast boot - changed the other settings to legacy—still has the same wait period. I’ll look at other BIOS options to see if anything else could have a bearing on it. Really scratching my head on this one…

OK, I read the sections in the manual, changed settings one-at-a-time & still have the same thing…GRRRRR this is getting frustrating. Starting to look like this maybe one I have to live with.

Have you looked at dmesg and journalctl for boot logs?

Try ‘clocksource=tsc’ kernel parameter

Maybe try tsc=unstable as a kernel parameter.