Boot Stuck wpa supplicant

Yes, not solved

Not solved.

How can I do that?

Uninstall the intel driver. It was in the post. Then it will be using modesetting.

sudo pacman -R xf86-video-intel

reboot

1 Like

Error : target not found

What does this show

cat  /etc/X11/xorg.conf
1 Like

No such file or directory

so you removed this before?
as it would be installed per default…

and only to clear this:
If you install proprietary Nvidia drivers on Optimus and set modesetting DRM on (what the installer does) default with nothing setup in addition that system will use intel GPU only and you can switch Nvidia on and of manually:

xrandr --listproviders will show info and names to use…
xrandr --setprovideroutputsource nvidia Intel

And it could be exactly the opposite … that you need the intel driver package be installed to get it working… some intel GPUs also if they are newer than gen 4 needs the Xorg driver …

1 Like

No I don’t remove that
How can I install it again?

yay -Syu xf86-video-intel

1 Like

After install intel driver
Xrandr --listprovider
Then i get this
Can’t open display

xrandr --listproviders

shows that it can not open display?
inxi -Ga
will show all about the two gpus and what drivers they are using…

And if you install Nvidia with nvidia-installer-dkms
you should have a working system.
Booting on intel and switchable to pull on nvidia GPU…

2 Likes

I’m install again nvidia driver using dkms( through chroot)
After that:
1

if x is not running Xrandr will not work :wink:

and you see:
2022-10-11_22-19
both drivers are loaded…

Could be something else is preventing from starting x ? like DM

2 Likes

How can I inspect that?

What was DE DM used?
Bootlog could tell:
journalctl -b -0 | eos-sendlog

1 Like

LightDM
Xfce
697072b6-249e-442a-8a1a-9dc3b1bc70e8

you have internet connection working? could be also clbin is blocked in your country…

yay -S fpaste
journalctl -b -0 > journal.txt && fpaste journal.txt
1 Like

yes I have connection but I’m from Iran most censorship and stuff
Document.odt (162.6 KB)

there is always a way :wink:

Process 1291 (Xorg) of user 0 dumped core.
is showing up repeately times in the log …

there is currently this BUG:

where it says it will bring nvidia to live when using:

ibt=off kernel boot option…

added manually to check by pressing “e” on grub boot menu and add it to kernel boot options:
2022-10-22_15-06

1 Like