Boot Stuck wpa supplicant

I have old endeavouros installation which I can’t remember what was the problem of this os at all
Anyway I’m guessing it’s graphic driver problem
Using inxi -Ga showed thah not any driver loaded
And stuck point was at “target reached graphical interface”
So I’m install Nvidia-470xx-dkms now the driver is load successfully but boot Stuck again but at different point >> [ok] wpa supplicant
How can I solve this problem?

a bit more info please e.g. which desktop manager are you using ?

1 Like

Xfce
Lightdm

Can you do a system-upgrade from within a shell?

sudo pacman -S archlinux-keyring , and then
sudo pacman -Syu, or simply yay

3 Likes

I consent with @ivanhoe post, also in the end
try

sudo systemctl status lightdm

sudo systemctl enable lightdm

sudo systemctl start lightdm

from the console ??

1 Like

Nice tips :wink:
Seems boot Stuck?
So press Ctrl+Alt+F3 login and remove the Nvidia package reboot and first fully Update system.

After this and if you will be able to start your de again… Next step :ladder:

2 Likes

I tried this one but open source Nvidia driver not loaded at all
I’ll try other solutions which our friends mentioned in above posts

What is the graphics hardware?

inxi -Ga
1 Like

run from live Bootable USB:

[liveuser@eos-2022.08.05 ~]$ inxi -Ga
Graphics:
Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo
driver: i915 v: kernel arch: Gen-5.75 process: Intel 45nm built: 2010
ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0416
class-ID: 0300
Device-2: NVIDIA GM107M [GeForce GTX 860M] vendor: Lenovo driver: nouveau
v: kernel alternate: nvidia_drm,nvidia non-free: 515.xx+ status: current
(as of 2022-07) arch: Maxwell code: GMxxx process: TSMC 28nm
built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1392 class-ID: 0302
Device-3: Acer Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 3-6:3
chip-ID: 5986:055e class-ID: 0e02 serial: 200901010001
Display: server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
loaded: intel,modesetting alternate: fbdev,nouveau,nv,vesa gpu: i915
display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 97 s-size: 420x236mm (16.54x9.29")
s-diag: 482mm (18.97")
Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x36ed built: 2013
res: 1600x900 hz: 60 dpi: 120 gamma: 1.2 size: 340x190mm (13.39x7.48")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2) v: 4.6 Mesa
22.1.4 direct render: Yes

i run this command many time from chroot in live bootable usb:

[root@EndeavourOS /]# sudo pacman -Syu
:: Synchronizing package databases…
core 156.2 KiB 47.6 KiB/s 00:03 [--------------------------------] 100%
extra 1715.0 KiB 308 KiB/s 00:06 [--------------------------------] 100%
community 7.0 MiB 481 KiB/s 00:15 [--------------------------------] 100%
multilib 175.3 KiB 68.1 KiB/s 00:03 [--------------------------------] 100%
endeavouros 33.4 KiB 6.91 KiB/s 00:05 [--------------------------------] 100%
:: Starting full system upgrade…
:: Replace wxgtk-common with extra/wxwidgets-common? [Y/n] n
resolving dependencies…
looking for conflicting packages…

is that possible Replace wxgtk-common with extra/wxwidgets-common cause this problem?
because when I choose yes it cant replace it ( dependency issue)

Open source driver is installed but it is running on Intel because it’s a hybrid system.
You shouldn’t be trying to install the 470xx Nvidia drivers as the GTX 860M is supported by the latest Nvidia drivers.

1 Like

Im try latest driver but problem not solved.
so you say the problem was another thing , yes?
ok Im going to install latest driver using dkms from live USB…

If you are trying to install it from the live usb you would have to use arch-chroot to do that. You can’t just boot on the live ISO and install it.

1 Like

already know that, thanks for reminding me.

[root@EndeavourOS /]# nvidia-installer-dkms
INFO:root:Removing /tmp/nvidia-installer_r.log file…
INFO:root:EndeavourOS Nvidia Installer v3.5
2022-09-21 08:23:48 [INFO]: EndeavourOS Nvidia Installer v3.5
INFO:root:All logs will be stored in /tmp/nvidia-installer_r.log
2022-09-21 08:23:48 [INFO]: All logs will be stored in /tmp/nvidia-installer_r.log
INFO:root:Updating Nvidia graphics cards database…
2022-09-21 08:23:48 [INFO]: Updating Nvidia graphics cards database…

Warning from nvidia-installer-update-db:
The nvidia.com site has database of card ids for the new driver (515.76).
Thus the nvidia.com database will reflect the new driver.
The driver from pacman has a different version (515.65.01).
It is recommended to run nvidia-installer-update-db again after having
the pacman version updated to the nvidia.com version.
Want to proceed with the db update (Y/n)? y
Database is already up-to-date.
INFO:root:Installing nvidia-dkms driver…
2022-09-21 08:24:31 [INFO]: Installing nvidia-dkms driver…
INFO:root:Removing conflicting packages…
2022-09-21 08:24:31 [INFO]: Removing conflicting packages…
INFO:root:Downloading and installing driver packages, please wait as this may take a few minutes…
2022-09-21 08:24:31 [INFO]: Downloading and installing driver packages, please wait as this may take a few minutes…
INFO:root:Unpatching /usr/share/applications/nvidia-settings.desktop…
2022-09-21 08:28:46 [INFO]: Unpatching /usr/share/applications/nvidia-settings.desktop…
INFO:root:Patching kernel line with nvidia-drm.modeset=1
2022-09-21 08:28:46 [INFO]: Patching kernel line with nvidia-drm.modeset=1
INFO:root:Installation finished. You need to reboot now!
2022-09-21 08:28:46 [INFO]: Installation finished. You need to reboot now!
[root@EndeavourOS /]#

Problem not solved and stuck again at [ok] reached Graphical interface

Sorry for external link I can’t upload any image here
Probably because of my country suffer from censorship from inside and sanctions from outside.

already tried un/reinstall lightdm ?

1 Like
sudo systemctl enable --now lightdm
1 Like

intel Gen-5.75 igpu? aka optimus hybrid notebook?

could be it works with the modesetting intel driver from kernel after uninstalling xf86-video-intel (xorg driver package)