Boot issue

I am unable to boot the EOS. While booting I am getting following error.

Unable to contract settings server.
Could not connect: connection refused.

It takes very long time to reach this message while booting. After the above message on desktop, i have touched the space bar, then I got weired xface desktop. Eventhough I wan unable to login. How to solve this issue or restore my lovely EOS.

Yesterday night I have upgraded the kernel to 5.7.3. I have usb with EOS. Shall I required to reinstall the EOS.

I couldn’t boot from kernel 5.7.3 yesterday when I came home late, but I didn’t have the time to enquire, and nor have I now. Work, work and work…

My temporary fix was to boot from the lts kernel.

I’m sure that someone can guide you hrough an lts kernel install, and/or even better solve the issue.

1 Like

Sir, How to boot from Lts kernel?

There are more people who are having trouble booting after the latest kernel update.

To install the lts kernel you can chroot into your system:

Then, type the following:

pacman -S linux-lts linux-lts-headers

then type:

grub-mkconfig -o /boot/grub/grub.cfg

and

mkinitcpio -p linux-lts

After that, you can exit the chroot environment, start up your system and select the lts kernel.

The last two steps might not be necessary anymore, according to some community members, due to a recent change, but better be safe than sorry.

how to reach terminal by booting usb drive?. please clarify

mount /dev/sdXn /mnt
( your “/” root partition)
mount /dev/sdXn /mnt/boot
In my case partion is sda7. In that case what is the command. Please help me to rescue my EOS. my loading through Grub4dos.

Replace the sdXn by sda7.

1 Like

Thank you Sir for prompt reply. I will get back to you after trying above technique.

Please see the error while running command

[root@archiso liveuser]# mount /dev/sda7 /mnt/boot
mount: /mnt/boot: mount point does not exist.
[root@archiso liveuser]# mount /dev/sda7 /mnt
[root@archiso liveuser]# pacman -S linux-lts linux-lts-headers
resolving dependencies...
looking for conflicting packages...

Packages (2) linux-lts-5.4.39-1  linux-lts-headers-5.4.39-1

Total Download Size:    88.46 MiB
Total Installed Size:  185.25 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
error: failed retrieving file 'linux-lts-5.4.39-1-x86_64.pkg.tar.zst' from ftp.myrveln.se : The requested URL returned error: 404
error: failed retrieving file 'linux-lts-5.4.39-1-x86_64.pkg.tar.zst' from mirrors.melbourne.co.uk : The requested URL returned error: 404
error: failed retrieving file 'linux-lts-5.4.39-1-x86_64.pkg.tar.zst' from mirror.mikrogravitation.org : The requested URL returned error: 404
error: failed retrieving file 'linux-lts-5.4.39-1-x86_64.pkg.tar.zst' from archlinux.polymorf.fr : The requested URL returned error: 404
error: failed retrieving file 'linux-lts-5.4.39-1-x86_64.pkg.tar.zst' from mirror.system.is : The requested URL returned error: 404
error: failed retrieving file 'linux-lts-5.4.39-1-x86_64.pkg.tar.zst' from ftp.ntua.gr : The requested URL returned error: 404
error: failed retrieving file 'linux-lts-5.4.39-1-x86_64.pkg.tar.zst' from ftp.icm.edu.pl : The requested URL returned error: 404~~~

I found this, maybe it would be worth reading.
https://bbs.archlinux.org/viewtopic.php?id=243268

This probably is a mirror issue, type sudo pacman -Syyu and then retry installing the lts kernel.

OK sir.

:: Synchronizing package databases...
 core                            133.2 KiB   136 KiB/s 00:01 [--------------------------------] 100%
 extra                          1706.6 KiB   327 KiB/s 00:05 [--------------------------------] 100%
 community                         4.9 MiB  1273 KiB/s 00:04 [--------------------------------] 100%
 multilib                        162.2 KiB  3.37 MiB/s 00:00 [--------------------------------] 100%
 endeavouros                      12.0 KiB  0.00   B/s 00:00 [--------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency

Packages (449) a52dec-0.7.4-11  aalib-1.4rc5-14  acl-2.2.53-3
               adobe-source-code-pro-fonts-2.030ro+1.050it-6  alsa-lib-1.2.3-1
               alsa-plugins-1:1.2.2-2  alsa-topology-conf-1.2.3-1  alsa-ucm-conf-1.2.3-2
               alsa-utils-1.2.3-1  amd-ucode-20200519.8ba6fa6-1  aom-2.0.0-1
               arc-gtk-theme-20200513-1  arch-install-scripts-23-2  archlinux-keyring-20200603-1
               argon2-20190702-3  aspell-0.60.8-2  atkmm-2.28.0-2  attica-5.71.0-1  attr-2.4.48-3
               automake-1.16.2-3  bash-5.0.017-1  bash-completion-2.10-2  bind-tools-9.16.4-1
               binutils-2.34-5  bison-3.6.3-1  broadcom-wl-dkms-6.30.223.271-22
               btrfs-progs-5.6.1-3  ca-certificates-mozilla-3.53.1-1  cairo-1.17.2+25+gaee96d175-1
               cairomm-1.12.2-4  cdparanoia-10.2-8  cmake-3.17.3-1  colord-1.4.4+9+g1ce26da-2
               cryptsetup-2.3.3-1  dav1d-0.7.0-1  dbus-1.12.18-1  dbus-glib-0.110-2
               dd_rescue-1.99.8-3  device-mapper-2.02.187-3  dkms-2.8.1-4  dmidecode-3.2-2
               double-conversion-3.1.5-2  downgrade-8.0.0-1  doxygen-1.8.18-2  e2fsprogs-1.45.6-2
               efitools-1.9.2-3  efivar-37-4  egl-wayland-1.1.5-1  eglexternalplatform-1.1-2
               elfutils-0.179-1  enchant-2.2.8-3  eos-update-notifier-1.7-1  ethtool-1:5.7-1
               exo-0.12.11-2  expect-5.45.4-2  extra-cmake-modules-5.71.0-1  f2fs-tools-1.13.0-2
               ffmpeg-2:4.2.3-1  ffmpegthumbnailer-2.2.2-2  fftw-3.3.8-3  file-5.39-1
               filesystem-2020.05.20-1  firefox-77.0.1-1  flac-1.3.3-2  fluidsynth-2.1.3-1
               fontconfig-2:2.13.91+48+gfcb0420-1  freetype2-2.10.2-1  fsarchiver-0.8.5-2
               fuse2-2.9.9-4  garcon-0.6.4-2  gc-8.0.4-4  gcc-10.1.0-2  gcc-libs-10.1.0-2
               geoip-1.6.12-2  geoip-database-20200609-1  giflib-5.2.1-2  git-2.27.0-1
               glib-networking-2.64.3-2  glib2-2.64.3-2  glibc-2.31-5  gnome-themes-extra-3.28-2
               gnu-netcat-0.7.1-8  gnupg-2.2.20-4  gnutls-3.6.14-1  gpart-0.3-4  gpgme-1.13.1-7
               graphene-1.10.0-2  grsync-1.2.8-1  grub-2:2.04-7  gst-libav-1.16.2-2
               gst-plugins-bad-1.16.2-13  gst-plugins-bad-libs-1.16.2-13  gst-plugins-base-1.16.2-2
               gst-plugins-base-libs-1.16.2-2  gstreamer-1.16.2-2  gtk-engine-murrine-0.98.2-4
               gtkmm3-3.24.2-2  gtksourceview3-3.24.11+28+g73e57b57-1  gupnp-igd-0.2.5+3+gedd78a6-3
               harfbuzz-2.6.7-1  harfbuzz-icu-2.6.7-1  haveged-1.9.12-1  hicolor-icon-theme-0.17-2
               hspell-1.4-3  hunspell-1.7.0-3  hwdetect-2016.01-3  hyphen-2.8.8-3
               iana-etc-20200601-1  imagemagick-7.0.10.19-1  imlib2-1.6.1-2  intel-ucode-20200616-1
               iproute2-5.7.0-1  iptables-1:1.8.5-2  iso-codes-4.5.0-1  jansson-2.13.1-1
               json-c-0.14-4  json-glib-1.4.4-2  karchive-5.71.0-1  kauth-5.71.0-1
               kbookmarks-5.71.0-1  kcodecs-5.71.0-1  kcompletion-5.71.0-1  kconfig-5.71.0-1
               kconfigwidgets-5.71.0-1  kcoreaddons-5.71.0-1  kcrash-5.71.0-1  kdbusaddons-5.71.0-1
               kded-5.71.0-1  keyutils-1.6.1-4  kglobalaccel-5.71.0-1  kguiaddons-5.71.0-1
               ki18n-5.71.0-1  kiconthemes-5.71.0-1  kio-5.71.0-1  kitemviews-5.71.0-1
               kjobwidgets-5.71.0-1  knotifications-5.71.0-1  kparts-5.71.0-1  krb5-1.18.2-1
               kservice-5.71.0-1  ktextwidgets-5.71.0-1  kwallet-5.71.0-1  kwidgetsaddons-5.71.0-1
               kwindowsystem-5.71.0-1  kxmlgui-5.71.0-1  l-smash-2.14.5-2  lame-3.100-3
               lcms2-2.11-2  ldb-1:2.1.3-1  leafpad-0.8.18.1-9  libarchive-3.4.3-1  libass-0.14.0-2
               libasyncns-0.8+3+g68cd5af-3  libatasmart-0.19-5  libavc1394-0.5.4-4
               libblockdev-2.24-1  libbsd-0.10.0-2  libbytesize-2.3-1  libcaca-0.99.beta19-3
               libcap-2.35-1  libcddb-1.3.2-6  libcdio-2.1.0-2  libcdio-paranoia-10.2+2.0.1-2
               libcroco-0.6.13-2  libdaemon-0.14-5  libdatrie-0.2.12-2
               libdbusmenu-qt5-0.9.3+16.04.20160218-5  libdc1394-2.2.6-2  libde265-1.0.5-2
               libdrm-2.4.102-1  libdv-1.0.0-9  libelf-0.179-1  libepoxy-1.5.4-2  libexif-0.6.22-1
               libfontenc-1.1.4-2  libgme-0.6.3-1  libgpg-error-1.38-1  libgphoto2-2.5.25-1
               libgudev-233-2  libibus-1.5.22+8+gf591381e-1  libice-1.0.10-3  libid3tag-0.15.1b-11
               libidn-1.35-3  libiec61883-1.2.0-6  libimobiledevice-1.2.0+87+g92c5462-7
               libinput-1.15.6-1  libinstpatch-1.1.5-1  libksba-1.4.0-1  liblqr-0.4.2-3
               libmicrohttpd-0.9.70-3  libmm-glib-1.12.10-1  libmodplug-0.8.9.0-3
               libmpcdec-1:0.1+r475-3  libmpeg2-0.5.1-7  libmspack-1:0.10.1alpha-3  libndp-1.7-2
               libnfnetlink-1.0.1-4  libnftnl-1.1.7-1  libnghttp2-1.41.0-1  libnice-0.1.17-1
               libnm-1.24.2-1  libofa-0.9.3-9  libogg-1.3.4-2  libomxil-bellagio-0.9.3-3
               libp11-kit-0.23.20-5  libpciaccess-0.16-2  libplist-2.1.0-3  libpng-1.6.37-2
               libpwquality-1.4.2-3  libqmi-1.24.14-1  libraqm-0.7.0-2  libraw1394-2.1.2-3
               librsvg-2:2.48.7-1  libsasl-2.1.27-3  libshout-1:2.4.3-3  libsidplay-1.36.59-10
               libthai-0.1.28-2  libtheora-1.1.1-5  libtiff-4.1.0-2  libtool-2.4.6+42+gb88cebd5-13
               libunwind-1.3.1-2  libutil-linux-2.35.2-1  libuv-1.38.0-1  libvdpau-1.4-1
               libvoikko-4.3-2  libvorbis-1.3.6-2  libvpx-1.8.2-2  libx11-1.6.9-7  libxau-1.0.9-3
               libxcomposite-0.4.5-3  libxcursor-1.2.0-2  libxdamage-1.1.5-3  libxdmcp-1.1.3-3
               libxext-1.3.4-3  libxfce4ui-4.14.1-3  libxfce4util-4.14.0-2  libxfixes-5.0.3-4
               libxfont2-2.0.4-3  libxft-2.3.3-2  libxi-1.7.10-3  libxinerama-1.1.4-3
               libxkbfile-1.1.0-2  libxmu-1.1.3-2  libxpm-3.5.13-2  libxrandr-1.5.2-3
               libxrender-0.9.10-4  libxslt-1.1.34-5  libxss-1.2.3-3  libxt-1.2.0-2
               libxtst-1.2.3-4  libxv-1.0.11-4  libxvmc-1.0.12-3  libxxf86vm-1.1.4-4
               libyaml-0.2.5-1  lightdm-1:1.30.0-3  lightdm-gtk-greeter-1:2.0.7-2
               linux-5.7.3.arch1-1  linux-api-headers-5.6.11-1  linux-firmware-20200519.8ba6fa6-1
               linux-headers-5.7.3.arch1-1  llvm-libs-10.0.0-2  lm_sensors-3.6.0-2  lrzip-0.631-3
               lvm2-2.02.187-3  lzop-1.04-3  man-db-2.9.2-1  man-pages-5.07-1  md4c-0.4.4-1
               media-player-info-24-2  memtest86+-5.01-4  mesa-20.1.1-1  mjpegtools-2.1.0-5
               mobile-broadband-provider-info-20190618-2  modemmanager-1.12.10-1  mousepad-0.4.2-3
               mpg123-1.25.13-2  nano-4.9.3-1  networkmanager-1.24.2-1  noto-fonts-cjk-20190409-2
               nss-3.53.1-1  nss-mdns-0.14.1-3  nvidia-440.82-22  nvidia-utils-440.82-2
               openconnect-1:8.10-1  opencore-amr-0.1.5-4  openexr-2.5.2-1  openjpeg2-2.3.1-2
               openssh-8.3p1-1  openssl-1.1.1.g-2  opus-1.3.1-2  orc-0.4.31-2  p11-kit-0.23.20-5
               pacman-5.2.1-6  pacman-contrib-1.3.0-2  pacman-mirrorlist-20200606-1  parted-3.3-2
               partimage-0.6.9-13  pavucontrol-1:4.0-2  pciutils-3.7.0-1  pcre2-10.35-1
               perl-5.30.3-1  perl-clone-0.45-1  perl-encode-locale-1.05-6
               perl-file-listing-6.04-7  perl-html-parser-3.72-9  perl-html-tagset-3.20-9
               perl-http-cookies-6.08-2  perl-http-date-6.05-2  perl-http-message-6.24-1
               perl-http-negotiate-6.01-7  perl-io-html-1.001-6  perl-libwww-6.45-1
               perl-lwp-mediatypes-6.02-7  perl-mailtools-2.21-3  perl-net-http-6.19-3
               perl-timedate-2.33-1  perl-try-tiny-0.30-4  perl-uri-1.76-3
               perl-www-robotrules-6.02-7  pigz-2.4-2  pkgconf-1.7.3-1  pkgfile-21-2
               polkit-qt5-0.113.0-2  portaudio-1:19.6.0-7  procps-ng-3.3.16-2
               progsreiserfs-0.3.0.5-10  pulseaudio-alsa-1:1.2.2-2  python-3.8.3-1
               python-appdirs-1.4.4-1  python-ordered-set-3.1.1-2  python-packaging-20.4-1
               python-ply-3.11-5  python-pyqt5-5.15.0-3  python-pyqt5-sip-12.8.0-1
               python-setuptools-1:47.3.1-1  python-sip-4.19.23-1  python-six-1.15.0-1
               qt5-base-5.15.0-3  qt5-declarative-5.15.0-1  qt5-location-5.15.0-1
               qt5-multimedia-5.15.0-1  qt5-speech-5.15.0-1  qt5-svg-5.15.0-1  qt5-tools-5.15.0-2
               qt5-webchannel-5.15.0-1  qt5-webengine-5.15.0-2  qt5-x11extras-5.15.0-1
               qt5-xmlpatterns-5.15.0-1  qt5ct-1.0-1  r8168-8.048.03-5  re2-1:20200601-1
               rhash-1.3.9-2  ristretto-0.10.0-3  rp-pppoe-3.14-1  sbc-1.4-2  sdl-1.2.15-14
               shared-mime-info-2.0+1+g6bf9e4f-2  smbclient-4.12.3-1  solid-5.71.0-1
               sonnet-5.71.0-1  sound-theme-freedesktop-0.8-4  soundtouch-2.1.2-2  spandsp-0.0.6-3
               speex-1.2.0-3  speexdsp-1.2.0-2  sqlite-3.32.2-1  squashfs-tools-4.4-2  srt-1.4.1-2
               startup-notification-0.12-7  sudo-1.9.0-1  systemd-245.6-7  systemd-libs-245.6-7
               systemd-sysvcompat-245.6-7  taglib-1.11.1-4  talloc-2.3.1-2  tcl-8.6.10-2
               tcpdump-4.9.3-2  testdisk-7.1-2  thunar-1.8.15-1  thunar-archive-plugin-0.4.0-3
               thunar-media-tags-plugin-0.3.0-2  thunar-volman-0.9.5-3  transmission-gtk-3.00-1
               tslib-1.21-2  ttf-bitstream-vera-1.10-13  ttf-caladea-20130214-3
               ttf-carlito-20130920-5  ttf-dejavu-2.37+18+g9b5d1b2f-1  ttf-liberation-2.1.1-1
               tumbler-0.2.8-2  udisks2-2.9.0-1  unrar-1:5.9.3-2  upower-0.99.11-2
               uriparser-0.9.4-1  util-linux-2.35.2-1  v4l-utils-1.20.0-1  vid.stab-1.1-3
               virtualbox-guest-dkms-6.1.10-1  virtualbox-guest-utils-6.1.10-1  vmaf-1.5.1-1
               volume_key-0.3.12-3  vpnc-1:0.5.3.r468.r81-1  vte-common-0.60.3-1  vte3-0.60.3-1
               vulkan-icd-loader-1.2.141-1  wavpack-5.3.0-1  webrtc-audio-processing-0.3.1-2
               welcome-2.8-1  wildmidi-0.4.3-2  x265-3.4-1  xcompmgr-1.1.8-2
               xdg-dbus-proxy-0.1.2-2  xdg-user-dirs-0.17-3  xdg-user-dirs-gtk-0.10+9+g5b7efc6-3
               xf86-input-libinput-0.30.0-1  xf86-input-vmmouse-13.1.0-5
               xf86-video-amdgpu-19.1.0-2  xf86-video-ati-1:19.1.0-2  xf86-video-fbdev-0.5.0-2
               xf86-video-intel-1:2.99.917+908+g7181c5a4-1  xfce4-appfinder-4.14.0-2
               xfce4-battery-plugin-1.1.3-2  xfce4-datetime-plugin-0.8.0-2
               xfce4-mount-plugin-1.1.3-2  xfce4-netload-plugin-1.3.2-2
               xfce4-screenshooter-1.9.7-2  xfce4-wavelan-plugin-0.6.1-2  xfce4-xkb-plugin-0.8.1-3
               xfdesktop-4.14.2-2  xfwm4-themes-4.10.0-4  xkeyboard-config-2.30-2
               xorg-font-util-1.3.2-2  xorg-font-utils-7.6-6  xorg-fonts-encodings-1.0.5-2
               xorg-setxkbmap-1.3.2-2  xorg-xauth-1.1-2  xorg-xdpyinfo-1.3.2-4  xorg-xinit-1.4.1-2
               xorg-xinput-1.6.3-2  xorg-xmodmap-1.0.10-2  xorg-xprop-1.2.4-2  xorg-xrandr-1.5.1-2
               xorg-xrdb-1.2.0-2  xvidcore-1.3.7-2  yay-10.0.1-1  zita-alsa-pcmi-0.3.2-3
               zita-resampler-1.6.2-3  zstd-1.4.5-1  zvbi-0.2.35-4

Total Download Size:   1000.45 MiB
Total Installed Size:  3555.26 MiB
Net Upgrade Size:        55.21 MiB

:: Proceed with installation? [Y/n]~~~

This is Ok Sir. Around 1GB to be download. Is it correct Sir. also confirm whether i have to apply/run pacman -S linux-lts linux-lts-headers after the completion of pacman - Syyu ?.

Yes

Costly Mobile data limitations. Otherwise, shall I re-install the EOS which is already available USB. Which one is good and easy.

If it’s installed on your drive and it’s up to date, you are on a rolling so no need to reinstall Eos but yes reinstall now linux-lts in following the @Bryanpwo help UP.

If already done a online install, I would vote for you just installing the lts kernel and it’s headers as mentioned above.

It will be less costly.

Please see my post No. 10. Error while installing linux-lts. Hence in a dilemma.

Sorry, I did not read that through.

The picture you’re showing is not in the chroot environment, but in the live iso. Chroot again, then perform pacman -Syyu and then follow the linux lts install I gave you.

Sir Please explain chroot command in simple step.