Boot Issue, grub. cfg not detected

I had grub install to thin local disk rather than the master Boot Record of the main hard drive and have been using Super grub disk to boot to the OS.

However the system crashed and after restarting the system, endevouros is no longer showing as a bootable entry, and grab. cfg is no longer detected.

Is there anyway to fix the issue, Maybe by the live iso?

This is not how grub should be installed, so if you want a solution, this is to install on a disk’s MBR (on a disk, not on a partition).
You should be able to do it with chroot from a live ISO.

1 Like

It is on a dish not a partition, should have been clearer, but I didn’t want to overwrite windows Bootloader so I installed grub to the mbr of the disk I installed endeavour OS on

Then it should be alright.
Reinstall the bootloader:

So you probably mean SuperGrub2 cannot find it. If you were more precise and detailed we wouldn’t do assumptions :man_shrugging:

I hope it is safe to assume you are running on a Legacy BIOS setup… :exploding_head:

In such a case, you would change Boot Disk Drive from BIOS to the one you have installed EnOS grub on. If this doesn’t work, then chroot and install grub again.

1 Like

OK the disk isn’t even showing in windows partition manager or bios. I’ve had issues with the pc case and cables coming loose, so that most probably is the issue

1 Like

This is what I get when I boot the SSD directly.

Any suggestions?

More than already done?

Give feedback on what you test.

1 Like

sudo fsck -t ext4 /dev/sdc
fsck from util-linux 2.37.2
e2fsck 1.46.4 (18-Aug-2021)
fsck.ext4: Input/output error while trying to open /dev/sdc

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem. If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193
e2fsck -b 32768

man fsck

fsck is used to check and optionally repair one or more Linux filesystems. filesystem can be a device name (e.g., /dev/hdc1, /dev/sdb2), a mount point (e.g., /, /usr, /home), or an filesystem label or UUID specifier (e.g., UUID=8868abf6-88c5-4a83-98b8-bfc24057f7bd or LABEL=root). Normally, the fsck program will try to handle filesystems on different physical disk drives in parallel to reduce the total amount of time needed to check all of them.

If no filesystems are specified on the command line, and the -A option is not specified, fsck will default to checking filesystems in /etc/fstab serially. This is equivalent to the -As options.

Use a partition with a file system (sdc1, sdc2, etc), i.e.:

sudo fsck -t ext4 /dev/sdc2
1 Like

/dev/sdc is where endeavouros is installed on (ext4) but won’t mount

I’m sorry, I am too old… :older_adult: This is basic knowledge. Please watch some nice videos about how Linux works and about drives and partitions.
Maybe someone else (in the forum) can walk you through… :man_shrugging:

1 Like

Sorry, this is only my third linux distro and I’ve never faced this issue before.


/dev/sdc is the device harddisk and not a partition what would be /dev/sdc1 /dev/sdc2 e.t.c. these are formatted with a filesystem not the drive …

this looks like erased system or using grub from a not installed system… could be also somehow grub is uninstalled and you can arch-chroot from live ISO and reinstall regenerate grub stuff:

It’s not mounted on /dev/sdc as everyone is pointing out. This a device or hard drive not the partition that it is installed.

Boot on the live ISO and maybe post

sudo parted -l

Edit: As suggested above you can arch-chroot from the Live ISO and reinstall grub and update it. Instructions were given with a link.