Boot into Blackscreen with Cursor with Xorg

Recently, I got an One by Wacom for free. Now I wanted to set it up and was following the Arch Wiki. At one point, I had to restart X. I tried it with startx, but it did not work, so I tried it with sudo startx. My screen turned black and also after restarting, I get the login screen, but after the login I just have a black screen with a cursor.

When I switch to tty and try to start X, I get a “SocketCreateListener(failed)” error message. According to the Wiki, I have to delete the socket files in /tmp/.X11-unix. I did that, but unfortunately it has not solved the issue.

In the Xorg Log, I can see only two errors:

[    17.829] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    17.830] (II) xfree86: Adding drm device (/dev/dri/card0)
[    17.849] (--) PCI:*(0@0:2:0) 8086:1916:17aa:2238 rev 7, Mem @ 0xf0000000/16777216, 0xe0000000/268435456, I/O @ 0x0000e000/64, BIOS @ 0x????????/131072
[    17.849] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    17.849] (II) LoadModule: "glx"
[    17.850] (II) Loading /usr/lib/xorg/modules/extensions/
[    17.854] (II) Module glx: vendor="X.Org Foundation"
[    17.854] 	compiled for 1.20.13, module version = 1.0.0
[    17.854] 	ABI class: X.Org Server Extension, version 10.0
[    17.854] (==) Matched intel as autoconfigured driver 0
[    17.854] (==) Matched modesetting as autoconfigured driver 1
[    17.854] (==) Matched fbdev as autoconfigured driver 2
[    17.854] (==) Matched vesa as autoconfigured driver 3
[    17.854] (==) Assigned the driver to the xf86ConfigLayout
[    17.854] (II) LoadModule: "intel"
[    17.854] (WW) Warning, couldn't open module intel
[    17.854] (EE) Failed to load module "intel" (module does not exist, 0)

Any idea what the issue could be?

Thanks and regards,

Must be something to do with this error.