Boot hangs at ‘Triggering uevents’

Hey everyone,

I already asked this question on Reddit, but got no answer so far so I figured I might as well ask in here.

I created a boot stick with Rufus but when I tried to boot into the live stick with the NVIDIA Graphics setting enabled, the stick hangs at ‘triggering uevents’.

I have a 3070 and I have had this problem with mutliple distributions already…
Should I boot into live without the proprietary drivers enabled and then try to install afterwards? This has only so far worked with Fedora but not with any other distro I tried…

Welcome to the forum! :smile:

That is one way of doing it.

Alternatively, if you have a recent Intel CPU (11xxx or newer) you might want to add a kernel parameter ibt=off in the boot menu entry.

Hey! Thanks for the quick answer!

I tried your solution and I was able to pass the inital error screen with the ‘triggering uevents’,
however I still have this issue that the GUI is not loading afterwards and I am just stuck with a terminal windows, that is spitting out logs of the system…

Is that what we’re trying to accomplish?

Thanks in advance!

what does it spit out?
Could you check in journalctl for errors with journalctl -p 3 -xb and since it’s not reaching the GUI you should also check /var/log/Xorg.0.log

Okay so I tried it once again today and for whatever reason it’s working now…

I used the kernel flag and proceeded which worked. However now I have another issue, when I tried to install EndeavourOS onto my 3rd SSD, it had a problem with the already present Windows boot partition.

This is the error log I get

I’ll try to install without creating my own partitions now and just use the sideload option and let the OS do it’s thing… I’ll keep you guys updated! Thanks for the help so far!

Update: So it turns out that Systemd-Boot didn’t recognize the boot partition on my main SSD and just defaulted to the boot partition of my live stick.

I am now stuck at

i915 0000:00:02.0: enabling device (0006 → 0007)

I can’t access the TTY console either, pressing ctrl + alt + F1-6 does nothing…
How can I provide more info?

So, you installed Endeavour OS and this is the last thing you see after passing the bootloader?

Yep, installation showed up as okay, rebooted and that’s what I saw after selecting “boot EndeavourOS” in Grub…

i915 ist a kernel module for Intel graphics. I have next to no knowledge about it.

There are wiki-pages regarding the topic:

And as you can’t boot the OS currently, you might need chroot from the live system:

I am sorry, but currently I have no time to look deeper into it.

Edit: grammar

Hmm, okay. Thanks for the info and for your help!

Anyone else have an idea what the fix could be?
Is there a way for me to disable the APU Graphics from a live system?

The same needs to be added to the installed system’s kernel parameters.
Try adding it at boot menu (systemd-boot keys).

Does it make a difference if I use GRUB instead of Systemd-boot?

Difference on what?
They are alternatives. They do the same task.
Use one or the other, properly, and there is no functional difference.
They have differences, but they can both provide a working system. :person_shrugging:

My bad, I just thought that you couldn’t enter those kernel flags on GRUB… :person_facepalming:

This worked perfectly fine! Thanks a lot!

Also thanks to everyone who has helped me in this thread!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.