Boot hangs at loading disk

So I tried to setup zram, which worked, rebooted and all. Then I decided to remove the swap partition, which I did then removed the entry from fstab. Now when I boot it hangs and tries to load the UUID for the old swap partition. I chrooted into the system and even tried making a new swap partition and adding it to the fstab but still no luck and it still looks for the old swap partition UUID.

I am new to dracut. Is there a command i need to refresh the boot image? I tried a coomand i found “sudo dracut --regenerate-all --force” but no luck.

sudo dracut-rebuild

Still no luck. It is still trying to load the old swap partition. I have seen this before when the fstab was jacked up, but it had the 1m30 limit. This job has no limit and will not boot.

Did you mount the efi partition in your chroot or before chrooting?


mount /dev/nvme…2 /mnt -o subvol-@
mount /dev/nvme…1 /mnt/boot/efi
arch-chroot /mnt

Did you do
Arch wiki

I used swapoff -a then rebooted.

So, how do I deactivate it in chroot so that it will boot?

Yeah, it get an error:

Running in chroot, ignoring command 'list-units'
1 Like

A long shot:

If you press e to edit the boot entry on the boot menu, do you see a resume=XXX-YYY… ?
If so could you delete it and go on booting?

I’ll try that when I get back. Had to run out.

Leave it to me though to break a system so bad chroot doesn’t even work. :stuck_out_tongue: :man_facepalming: I really need to learn some code and be a bug finder instead of the bug creator.

1 Like

I think I might have been out biking suggesting that. If you haven’t set up resume/hibernation there will be no resume=XXX-YYY… :man_facepalming:t5:

It might work. The only reason I say that is I remember seeing something about resume when it was booting.

Yeah, ran into a snag. My screen is broken on the right side and cant read it and my external doesn’t work at this point.

Here is where it is stuck:

Found it. Chrooted in and opened grub.cfg. The “resume” option was listed in all instances. If i delete all them then rebuild grub it should work, right?

1 Like

Yes and I guess If you are using dracut there should be some config in


with some line like

add_dracutmodules+=" resume "

Remove that as well and then rebuild your boot images plus updating your grub.cfg.

By the way, you need to remove resume=XXX,YYY… in /etc/default/grub and not in grub.cfg

Then, run:

# grub-mkconfig -o /boot/grub/grub.cfg

Sorry; I missed that.

Ok, do I still need to delete the ones on grub.cfg, or just take out the module in default/grub ?

Just this.

The grub.cfg will be overwritten when you run the grub-mkconfig command.

1 Like