Boot broken, modules.devname not found

I’m not able to boot into EndeavourOS. I get an error “warning lib/modules/6/6/29-1-lts/modules.devname not found” and then it tells me my device UUID is not found. I was able to boot into Windows to make an EndeavourOS installer USB, and I can read the drives, backup files, etc. from the installer.

I have used arch-chroot to get into my system. It looks like similar problems have been fixed with mkinitcpio, so I tried to run mkinitcpio - p which ran successfully, but I’m getting the same error. It seems to be looking for something old, but I’m not sure why. Or what I might have done.

At this point, I feel out of my depth. Can someone help?

From the arch-chroot can you share the output of pacman -Qq | grep -E "dracut|grub|mkinit"

Yes, thanks.

[root@EndeavourOS /]# pacman -Qq | grep -E “dracut|grub|mkinit”
grub
grub-customizer
mkinitcpio
mkinitcpio-busybox
mkinitcpio-nfs-utils
mkinitcpio-openswap

From the chroot, try running sudo pacman -Syu linux-lts linux-lts-headers

Thank you. That reinstalled successfully, everything successful (with the regular “possibly missing firmware” messages.) Would I try to reboot at this point?

Yes

That did it. I’m in. Thank you so much!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.