Blurry secondary screen with plasma

Hi guys,
I’ve recently bought an external monitor for my laptop (DELL Inspiron 7577 with Nvidia 1060 GTX 6Gb) and I’ve noticed that the monitor, when connected, is very blurry.
I’ve tried with Gnome and I don’t have the problem. Right now I’m using Nvidia proprietary drivers because I need those, but also nouveau give the same result. Only Intel is not possible because the Nvidia card is directly connected to the HDMI output, so the integrated as no access to it (also need Nvidia driver for rendering, al already stated).
Any help?

Wayland or X?

sorry your are right, Wayland for now

1 Like

You know what to do…Try X, if it works good - use X, report Wayland bug to KDE bugtracker unless it wasn’t already reported.


Silly of me to not think of it.
But…I’ve tried X and it’s even worse! panel doesn’t load (is rendered empty and green) no icons in the menu and font completely borked. Oh and secondary screen still blurry -.-

wow…for now i’m out of ideas.

I wonder maybe if xrandr for second monitor would help at least temporary?

Perhaps also try to switch for LTS Kernel, in case you use latest

Sadly no dice with lts too (that also now as switched to 6 series soooo…). I really don’t know what to think .-.

1 Like

Perhaps @petsam can come up with some debug method / advise, that sounds like type of problem right up his alley :sweat_smile:

1 Like

Since Gnome is fine, it seems not a system configuration issue.

For Plasma, test several combinations at the Compositor Settings page.

Also, some cache and/or configuration files cleanup, resets such issues (at times).

1 Like

I’ll try to mess with the compositor combination. Resetting I don’t think will do anything because I’ve it also on fresh install

Edit: nothing even with compositor changes. Also noticed that fonts in gtk apps are very pixelated. I don’t really know what borked this installation :thinking:

1 Like