Bluetooth Timeouts

Hello everyone.

Recently I moved back to EndeavourOS with KDE and installed the linux-zen kernel. Currently, I’m running the version “6.4.4-zen1-1” (6.4.4.arch1-1 has the same issue). My laptop has a MT7921K - a wifi and bluetooth bundle - (which seems to be a rebrand of the AMD RZ608 - or vice versa) which, of my knowledge, is supported on this kernel. (lspci output at the end)

I’ve taken a look into the linux hardware website where it states that this pcie card is only supported up to the kernel 6.3. I don’t know how reliable this website is so I decided to check here.

Taking those conclusions, I’ve moved into the lts kernel (currently 6.1.39-1 which was the version I was running on ubuntu 23.04) and it works with no issues at all.

I have to say as well that both of the kernels mentioned in the beginning of this post do have some random kernel panics. They already happened when doing nothing / opening apps and even when shutting down the system. I would love to add kernel panic logs here, however I’m not aware of how to get those logs.

Now focusing on the bluetooth issue: When I boot into the system (zen or arch kernel) both WiFi and Bluetooth work. After some time I can’t use bluetooth and I have to go to KDE settings and disable bluetooth. After that, I have to enable bt back on. If I don’t do this, the bluetooth feature is unavailable until I shutdown the system and wait a few seconds. When it becomes unavailable, the UI it says that no adapters were found and the error is the same as the given below on dmesg. The solution for this case is to shutdown the system and wait a few seconds to turn it back on again or force the system to shutdown by holding the power button.

I would like to have this issue fixed as the latest kernel as some optimizations for AMD CPUs.

When bluetooth timed out today I checked dmesg and got the following:

[  266.219053] usb 3-3: reset high-speed USB device number 2 using xhci_hcd
[  288.579874] Bluetooth: hci0: Execution of wmt command timed out
[  288.579882] Bluetooth: hci0: Failed to send wmt func ctrl (-110)
[  300.354535] Bluetooth: hci0: Execution of wmt command timed out
[  300.354547] Bluetooth: hci0: Failed to send wmt patch dwnld (-110)
[  300.354590] Bluetooth: hci0: Failed to set up firmware (-110)
[  300.354594] Bluetooth: hci0: HCI Enhanced Setup Synchronous Connection command is advertised, but not supported.
[  302.402377] Bluetooth: hci0: Failed to read MSFT supported features (-110)
[  302.402376] Bluetooth: hci0: command 0xfd30 tx timeout
[  304.450152] Bluetooth: hci0: AOSP get vendor capabilities (-110)
[  304.568631] usb 3-3: reset high-speed USB device number 2 using xhci_hcd
[  307.695861] Bluetooth: hci0: Device setup in 2926332 usecs
[  307.695874] Bluetooth: hci0: HCI Enhanced Setup Synchronous Connection command is advertised, but not supported.
[  307.761632] Bluetooth: hci0: AOSP extensions version v1.00
[  307.761644] Bluetooth: hci0: AOSP quality report is supported
[  307.761953] Bluetooth: MGMT ver 1.22

I see that on dmesg it is listed as a usb device. Maybe the bluetooth part of the card is linked to the usb bus?

Thanks in advance.

If you are dual booting with Windows? Make sure the fast startup feature in Windows power management is disabled.

I only have EndeavourOS installed. Secureboot, tpm and fast boot are disabled.

If required, the laptop I’m using is a MSI Modern 15 A5M

Is the WiFi a usb dongle or built in? Bluetooth is on the same chip i think.

WiFi and Bluetooth are in a pcie card.
As I mentioned on the post, I think the bluetooth is just linked to the usb bus. (that shouldn’t be an issue?)

It could be a powersave issue?

Edit: Maybe try this:

I am running tlp which sets the PCIE_ASPM_ON_BAT to powersupersave and _ON_AC to default.

Maybe that could be the issue?

By the link you’ve provided, won’t it disable the bluetooth functionality? (from what I understood it will)

Ya sorry that’s not exactly what i was meaning to link. I’m trying to find the way to set power save on this WiFi to turn it off! No powersave!

Maybe try changing this setting.

Alright, will set it to default and I’ll test it around for some time

Also, might be important to remember. On the network area of tlp, there is a setting named WIFI_PWR_ON_BAT which refers to wifi power saving mode.

Should that be disabled as well?

That also may be the one needed. I don’t really know so you are going to have to test both of those possibilities and see if it makes any difference.

I’ve disabled both and I’ll change to the zen kernel. I’ll test it out through the next hours/days to see if any bluetooth issue or kernel panic occurs. Thanks for the help

After almost two weeks I’ve been doing some testing with the various options of the tlp power management.

This is what fixed the issue:

  • Leaving PCIE_ASPM_ON_BAT at the default so that it wouldn’t conflict with the bios setting

Thanks for all the help provided along this thread and hope this can help somebody out.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.