Bluetooth switches to mSBC

Hey all,

I use Bluetooth for my headset and my preferred codec is aptX because my headphones support it. Whether on KDE or Gnome over the past few years, if I switch into a game or something on steam, the headset briefly switches back to mSBC according to PulseAudio volume control and then back. I have migrated to KDE6 via a new EOS install and I’ve noticed that the handling of the audio codecs is less consistent, particularly on returning to aptX.

Is there a way I can disable mSBC entirely or set aptX as preferred?

I’m not sure if there are ways to to do that, but I found this in the Arch Wiki: https://wiki.archlinux.org/title/PipeWire#Automatic_profile_selection

Basically, it disables the automatic profile switching altogether.