Bluetooth headset issues

Hey Everybody

Im using the latest release. With a mate desktop. pulseaudio installed.
Installed pulseaudio-modules-bt-git to get the different codecs installed. (non-free)

Problem:
The codecs show up as you can see in the image. But they only work with the speakers, not the mic. Except the HSP/HFP option. IF i choose that codec. Both mic and audio is working, but only in mono and with bad sound quality.

Question:
Can I get the MIC working with the quality codecs as well ? And how.

Did you install any of the bluetooth from welcome screen?

Yes I did.

It “only” links to the wiki. I read it and installed the following

pacman -S --needed bluez bluez-utils blueman && sudo systemctl start bluetooth && sudo systemctl enable bluetooth && sudo reboot

But the Headphones would not pair via the GUI (GUI seen in image…) So.

sudo pacman -S pulseaudio-alsa pulseaudio-bluetooth && sudo reboot

Now the headset can be paired in the GUI and Mic and Speakers working. But only in low quality (HSP/HFP). So.

yay pulseaudio-modules-bt-git libldac

Now I can listen in A2DP > LDAC,aptX but the Mic is still not working. And I`m kind of stuck. But pulseaudio is the issue for sure. Some config info here.

A little confirmation that the codes actually are available.

$ pactl list | grep -C2 A2DP
Profiles:
headset_head_unit: Headset Head Unit (HSP/HFP) (sinks: 1, sources: 1, priority: 30, available: yes)
a2dp_sink_sbc: High Fidelity Playback (A2DP Sink: SBC) (sinks: 1, sources: 0, priority: 40, available: yes)
a2dp_sink_aac: High Fidelity Playback (A2DP Sink: AAC) (sinks: 1, sources: 0, priority: 40, available: yes)
a2dp_sink_aptx: High Fidelity Playback (A2DP Sink: aptX) (sinks: 1, sources: 0, priority: 40, available: yes)
a2dp_sink_aptx_hd: High Fidelity Playback (A2DP Sink: aptX HD) (sinks: 1, sources: 0, priority: 40, available: yes)
a2dp_sink_ldac: High Fidelity Playback (A2DP Sink: LDAC) (sinks: 1, sources: 0, priority: 40, available: yes)
off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
Aktive profil: a2dp_sink_ldac

$ sudo systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
Active: active (running) since Sun 2020-04-19 01:04:30 EEST; 9min ago
Docs: man:bluetoothd(8)
Main PID: 791 (bluetoothd)
Status: “Running”
Tasks: 1 (limit: 8815)
Memory: 2.9M
CGroup: /system.slice/bluetooth.service
└─791 /usr/lib/bluetooth/bluetoothd

Apr 19 02:04:32 pibook bluetoothd[791]: Endpoint registered: sender=:1.39 path=/MediaEndpoint/A2DPSource/SBC
Apr 19 02:04:32 pibook bluetoothd[791]: Endpoint registered: sender=:1.39 path=/MediaEndpoint/A2DPSink/VENDOR/APTXHD
Apr 19 02:04:32 pibook bluetoothd[791]: Endpoint registered: sender=:1.39 path=/MediaEndpoint/A2DPSink/VENDOR/APTX
Apr 19 02:04:32 pibook bluetoothd[791]: Endpoint registered: sender=:1.39 path=/MediaEndpoint/A2DPSink/AAC
Apr 19 02:04:32 pibook bluetoothd[791]: Endpoint registered: sender=:1.39 path=/MediaEndpoint/A2DPSink/SBC
Apr 19 02:04:52 pibook bluetoothd[791]: /org/bluez/hci0/dev_38_18_4C_22_13_4C/sep5/fd0: fd(45) ready
Apr 19 02:06:36 pibook bluetoothd[791]: /org/bluez/hci0/dev_38_18_4C_22_13_4C/sep6/fd1: fd(41) ready
Apr 19 02:06:45 pibook bluetoothd[791]: /org/bluez/hci0/dev_38_18_4C_22_13_4C/sep5/fd2: fd(41) ready
Apr 19 02:11:44 pibook bluetoothd[791]: /org/bluez/hci0/dev_38_18_4C_22_13_4C/sep6/fd3: fd(41) ready
Apr 19 02:11:53 pibook bluetoothd[791]: /org/bluez/hci0/dev_38_18_4C_22_13_4C/sep5/fd4: fd(41) ready

Did you look at the info here?

https://wiki.archlinux.org/index.php/Bluetooth_headset#Headset_via_Bluez5/PulseAudio

Edit: You may need the package called ofono?

I got a bluetooth card for my Dell E6400 Laptop and I added all the Bluez stuff per the Wiki and still could not get it to work until I found this article on the Arch forum and at the end the person said to fix most of the bluetooth issues he was having was to also install “bluez-hid2hci” he also stated it should be part of the Bluez master package… (Their words)
So installed that package and all my bluetooth issue were fixed. Not sure that this will help you but there it is for ya to try…
Maybe @ricklinux might know more about this, he’s real sharp guy… :slight_smile:
LLAP

1 Like