Bluetooth Automatically connects to Device

Fresh install of EOS automatically connects to bluetooth devices upon start up & logging back in. I have executed the following commands:

systemctl enable bluetooth

systemctl start bluetooth

Ok. . . And what would you like the outcome to be since that starts and enables it.

What DE?

Cheers, Derek! I realize I should have contextualized more.

I’d like to have Bluetooth on, but not connect every time I get to the GDM log-in screen.

I’m not 100%, but I believe if you go into your dconf settings and search bluetooth, you will want to uncheck this option.

It SHOULD not automatically reconnect to bluetooth items any longer.

Screenshot from 2022-09-08 04-57-48

It may also turn off your bluetooth on startup. . . otherwise I don’t think there’s a way for both options. It’s probably all or nothing.

I don’t have time to try now, time for work!

That seems somewhat contradictory in itself. Why would you want BT to be always on, and not connect?
Gnome has decided to always enable BT from the login to a session only some 2 yrs. or so ago.

If you dont want that, you can disable BT from session start and only enable it when you want it to connect. Maybe, your computer also has a hardware-switch for turning BT on/off, which would make things easier in a way.

Via shell-cmd, you can also turn BT on/off easily:

bluetoothctl power on , or bluetoothctl power off

Also see this.

1 Like

That way, you’d always have to pair devices anew, after reboot, because they wont be remembered as being paired before.

1 Like


I dunno then. I’m always happy to have everything reconnected when I turn my computer back on, so I’ve never looked that hard.

This. :point_up_2:

I have wireless earbuds, a mouse, and a stereo network streamer. I would prefer that I didn’t have to disconnect them every time I booted my machine up.

Why not just just start Bluetooth when you want to connect things but disable it. That way every time you turn the computer on, Bluetooth is off and therefore not connected to anything?

Using three different BT audio sinks intermittently requires switching the unwanted devices off, before putting the wanted device to use by turning it on, as BT cannot connect to more than one device at a time.

What good would it do draining their batteries when letting them try to connect all the time, though they are not in use?



Wow, there’s no pleasing people. :joy:

Some people want the exact opposite… e.g. those who want to connect to Bluetooth speakers, and especially those who want a working BT mouse and keyboard!


Well the network streamer is always on; @fbodymechanic’s suggestion is the more practical one in this case.

The behavior of what I’m trying to achieve occurs on my other, non-EOS machine, so I was just trying to get them to behave similarly. This EOS machine seems to just want to connect to the streamer every time upon boot up. I will follow Derek’s suggestion.