Bluetooth adapter not working after fresh EOS install

A few days ago I reinstalled EOS from a current ISO. (I retained my home partition.) I think it initially worked for a short while, but today I noticed bluetooth not working. I’m using KDE and the tray icon is greyed out. When I hover over it, it says “No adapters available”. When I go to bluetooth settings, it says "Bluetooth is disabled. I cannot find helpful errors. I tried with several different Kernels, including lts, lts54 and zen. No difference.

I’m using a ThinkPad t440s, which has a built-in Intel bluetooth adapter, which has reliably worked before the OS reinstall. I already tried restarting bluetooth.service. I do not recall changing any related system settings. What follows are the outputs of several relevant commands:

$ hciconfig -a
hci0:   Type: Primary  Bus: USB
        BD Address: 28:B2:BD:3C:DE:CA  ACL MTU: 1021:5  SCO MTU: 96:5
        UP RUNNING 
        RX bytes:1676 acl:0 sco:0 events:147 errors:0
        TX bytes:25381 acl:0 sco:0 commands:155 errors:0
        Features: 0xff 0xfe 0x0f 0xfe 0xdb 0xff 0x7b 0x87
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
        Link policy: RSWITCH HOLD SNIFF 
        Link mode: PERIPHERAL ACCEPT 

        Name: 'Bluemoon Universal Bluetooth Host Controller'
Can't read class of device on hci0: Connection timed out (110)
$ systemctl status bluetooth.service 
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2022-04-24 01:42:51 CEST; 17min ago
       Docs: man:bluetoothd(8)
   Main PID: 37371 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 9141)
     Memory: 860.0K
        CPU: 48ms
     CGroup: /system.slice/bluetooth.service
             └─37371 /usr/lib/bluetooth/bluetoothd

Apr 24 01:42:51 hauke-thinkpad systemd[1]: Starting Bluetooth service...
Apr 24 01:42:51 hauke-thinkpad bluetoothd[37371]: Bluetooth daemon 5.64
Apr 24 01:42:51 hauke-thinkpad systemd[1]: Started Bluetooth service.
Apr 24 01:42:51 hauke-thinkpad bluetoothd[37371]: Starting SDP server
Apr 24 01:42:51 hauke-thinkpad bluetoothd[37371]: Bluetooth management interface 1.21 initialized
$ lsmod | grep bt
btrfs                1794048  1
xor                    24576  1 btrfs
raid6_pq              122880  1 btrfs
libcrc32c              16384  5 nf_conntrack,nf_nat,btrfs,nf_tables,xfs
btusb                  69632  0
btrtl                  28672  1 btusb
btbcm                  24576  1 btusb
btintel                49152  1 btusb
btmtk                  16384  1 btusb
bluetooth             909312  23 btrtl,hidp,btmtk,btintel,btbcm,bnep,btusb,rfcomm

$ journalctl -xb | grep blue
https://clbin.com/7gLD1

$ sudo dmesg | grep blue
[    3.540226] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[ 1083.633776] audit: type=1131 audit(1650756748.704:195): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=blu
etooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 1106.538082] audit: type=1130 audit(1650756771.609:226): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=blu
etooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 1706.677578] audit: type=1131 audit(1650757371.752:262): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=blu
etooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 1706.727496] audit: type=1130 audit(1650757371.801:263): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=blu
etooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

$ sudo lspci -nnk | grep -iA2 net; lsusb; rfkill list all; uname -a; dmesg | egrep -i 'blue|firm'
https://clbin.com/lc3Ie

When I had KDE Plasma 5.23, I had a similar problem, but with a Broadcom bt, so I removed btusb

sudo modprobe -rfv btusb

then reloaded it

sudo moprobe -v btusb

then checked if it running again

sudo dmesg | grep -i blue

then do hciconfig again

hciconfig -a

Then I was able to enable the bt in the system tray.

Hope it works.

That didn’t change anything.

Do you have bluedevil installed?

Yes.

pacman -Qs blue
https://clbin.com/hW5kh

Forgot to mention that I tried using both bluez-utils and bluez-utils-compat, which is why I could use hciconfig -a. Neither package gets bluetooth working though.

You know it’s kinda strange that hciconfig -a says Bluemoon Universal Bluetooth Host Controller when I have an Intel controller.

Oh sorry I only just saw this answer. It didn’t work, but the output of dmesg changed:

[    3.275666] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[    4.825793] Bluetooth: Core ver 2.22
[    4.825818] NET: Registered PF_BLUETOOTH protocol family
[    4.825820] Bluetooth: HCI device and connection manager initialized
[    4.825824] Bluetooth: HCI socket layer initialized
[    4.825827] Bluetooth: L2CAP socket layer initialized
[    4.825831] Bluetooth: SCO socket layer initialized
[    5.201945] Bluetooth: hci0: Legacy ROM 2.5 revision 8.0 build 2 week 3 2013
[    5.201952] Bluetooth: hci0: Intel device is already patched. patch num: 57
[    6.934814] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    6.934817] Bluetooth: BNEP filters: protocol multicast
[    6.934821] Bluetooth: BNEP socket layer initialized
[   36.594517] Bluetooth: hci0: command 0x0c14 tx timeout
[   38.641745] Bluetooth: hci0: command 0x0c23 tx timeout
[  347.585569] Bluetooth: hci0: urb 0000000005985ebe failed to resubmit (2)
[  363.699186] Bluetooth: hci0: Legacy ROM 2.5 revision 8.0 build 2 week 3 2013
[  363.699193] Bluetooth: hci0: Intel device is already patched. patch num: 57

Another curious thing:

$ hcitool scan
Scanning ...
Inquiry failed: Device or resource busy
sudo modprobe -r btusb
sudo modprobe btusb

Edit: Have you used bluetoothctl and gone through all the steps? Sometimes you have to clear everything and start over!

1 Like

Aren’t those commands equivalent to HMS_Endeavour’s suggestion? In any case it doesn’t change anything unfortunately.

I am pretty sure I have gone through all the steps at least once by now. Bluetoothctl doesn’t detect any controllers at all. With regards to bluetoothctl, my problem looks like this: https://wiki.archlinux.org/title/bluetooth#bluetoothctl:_No_default_controller_available But none of the suggestions there work.

rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
4: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

I have booted with btusb.enable_autosuspend=n too.

Maybe this part of journalctl says something? I have no idea.

Apr 24 20:04:43 hauke-thinkpad sudo[10525]:    lutra : TTY=pts/0 ; PWD=/home/lutra ; USER=root ; COMMAND=/usr/bin/s
ystemctl enable bluetooth.service
Apr 24 21:05:29 hauke-thinkpad bluetooth-meshd[424]: Hci dev 0000 removed
Apr 24 21:05:29 hauke-thinkpad bluetooth-meshd[424]: Failed to read info for hci index 0: Invalid Index (0x11)
Apr 24 21:05:29 hauke-thinkpad bluetoothd[4947]: src/adapter.c:index_removed() Ignoring index removal for a non-exi
stent adapter
Apr 24 21:05:29 hauke-thinkpad bluetoothd[4947]: src/adapter.c:reset_adv_monitors_complete() Failed to reset Adv Mo
nitors: Invalid Index (0x11)
Apr 24 21:05:29 hauke-thinkpad bluetoothd[4947]: Failed to read exp features info: Invalid Index (0x11)
Apr 24 21:05:29 hauke-thinkpad bluetoothd[4947]: Failed to read info for index 0: Invalid Index (0x11)
Apr 24 21:05:33 hauke-thinkpad bluetooth-meshd[424]: Hci dev 0000 removed
journalctl -b | grep -i bluetooth

https://clbin.com/xuADs

doesn’t look very informative to me. i’m gonna go ahead and add
journalctl -max --grep blue
https://clbin.com/jDvt4

Try disabling these services and reboot and see if it makes any difference.

systemctl disable bluetooth-meshd.service
systemctl disable blueman-mechanism.service
3 Likes

Disabling bluetooth-mesh.service did the trick, thank you!
(I don’t have blueman installed.)

It was a lucky guess on my part.

2 Likes

From the log it seems like I manually enabled that service shortly after I installed EOS, possibly in an attempt to make bluetooth work while it was disabled in /etc/bluetooth/main.conf - if so, my bad. But I don’t really remember.

I don’t’ know either it just looked out of place with all the Bluetooth i have done.

You are far too modest Rick. I don’t know where would be without you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.