Blueman manager seems to get a little weird

I use blueman-manager on Endeavour OS Xfce edition. But I can’t connect to Bluetooth.
Previously (several days ago) it still works.

My step to reproduce:

  1. Turn on the bluetooth device (in my case a wireless speaker) and of course turn on the bluetooth on the device.
  2. Open blueman-manager, either with cmd or system tray.
  3. Click search.

Blueman seems to be searching for a device. But suddenly all of the previously listed device dissappeared. Then it appears again, and dissappears again (in a loop). Hence making me unable to connect to one of these devices. Turning off the device seems to temporarily stops the problem, the device list doesn’t get weird again like before. But still, I can’t connect to bluetooth. I have tried to switch to lts kernel version (I heard it may solve the problem). But still doesn’t work. How can I solve this problem?

Please tell me which command to execute if any. Im no expert here.

Delete all previously paired devices and pair them again. This usually helps.

For the command-line, man bluetoothctl


It works!! Thanks man.
Didn’t expected the solution to be really easy.
BTW, is it some kind of a bug on blueman manager?

1 Like

I’d rather say, it is a general thing in Linux overall… :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.