Blender GPU suddenly unsupported

Recently i updated my system, providing myself with the latest blender, and also updating GPU drivers.
Before blender was working fine, but now when i start it i am immediately greeted by:

Your graphics card or driver is not supported.

Newer graphics drivers may be available to improve Blender support

 Graphics Card: Mesa AMD BARTS (DRM 2.50.0) / 6.6.12-1-lts, LLVM 16.0.6) 4.5 (Core Profile) Mesa 32.3.3-arch1.1

This program will now close

This menu also provides two options:

And yes i know that the “Find Latest Drivers” link doesn’t work, but that is what the button sends me too.

From the EOS log tool: https://0x0.st/H0Fg.txt

What can i do to rectify this issue?
I am using an old Radeon HD radeon hd 6850, i know it is old and not really fast by any standard, but it worked a few months ago.

I have also noticed several graphical artefacts since around the time of the update, specifically in vivaldi when loading multimedia, not sure if this is linked.

Any advice? or is this something completely unrelated to linux and something I need to go directly to blender support for?

○ → blender --version
Blender 4.0.2
        build date: 2024-01-16
        build time: 15:01:28
        build commit date: 2023-12-05
        build commit time: 07:41
        build hash: 9be62e85b727
        build platform: Linux
        build type: Release
        build c flags:  -Wall -Werror=implicit-function-declaration -Wstrict-prototypes -Werror=return-type -Werror=vla -Wmissing-prototypes -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wlogical-op -Wundef -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Wformat-signedness -Wrestrict -Wno-stringop-overread -Wno-stringop-overflow -Wnonnull -Wabsolute-value -Wuninitialized -Wredundant-decls -Wshadow -Wimplicit-fallthrough=5 -Wno-error=unused-but-set-variable  -fopenmp -std=gnu11 -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -ffp-contract=off -msse2  
        build c++ flags:  -Wuninitialized -Wredundant-decls -Wall -Wno-invalid-offsetof -Wno-sign-compare -Wlogical-op -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Werror=return-type -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wundef -Wcomma-subscript -Wformat-signedness -Wrestrict -Wno-suggest-override -Wuninitialized -Wno-stringop-overread -Wno-stringop-overflow -Wimplicit-fallthrough=5 -Wundef -Wmissing-declarations  -fopenmp -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -ffp-contract=off -msse2  
        build link flags:  -Wl,--version-script='/build/blender/src/blender/source/creator/symbols_unix.map' -latomic
        build system: CMake

tried also with latest Kernel version or is only LTS in use?

https://docs.blender.org/manual/en/dev/troubleshooting/gpu/linux/amd.html#unsupported-graphics-driver-error

Just tried with the latest kernel version, same issue exactly.

Through Terminal:

○ → blender
Warning: Unsupported platform as it supports max 0 SSBO binding locations

Blender quit

EDIT: Just looked up on this and https://projects.blender.org/blender/blender/issues/116837
Seems the cards the year (southern islands, whereas my card is northern islands) after are now as far back as blender supports. Would of nice if they simply wrote this in their main docs but anyway.

Is there a nice way to downgrade my blender version to something like 3.6LTS?
I don’t see a LTS package in the arch repo.

@yetanotheruser
Blender supports GCN generation 2 and above. The Radeon 6850 Is Terra Scale2

https://aur.archlinux.org/packages/blender-3.6-bin

AUR have it