Blender 4.0.1 doesn't start

Hey all

When I start Blender I get this error:

blender
Writing: /tmp/blender.crash.txt
Speicherzugriffsfehler (Speicherabzug geschrieben)

(from blender.crash.txt)

Blender 4.0.1, Commit date: 2023-11-16 16:40, Hash d0dd92834a08

backtrace

blender(+0xfd0683) [0x55c25e5c7683]
blender(+0x8ba21e) [0x55c25deb121e]
/usr/lib/libc.so.6(+0x3e710) [0x7f5e05e5c710]
/usr/lib/libLLVM-15.so(+0x17a7a0f) [0x7f5dfa9a7a0f]
/usr/lib/libLLVM-15.so(+0x17a7b98) [0x7f5dfa9a7b98]
/usr/lib/libLLVM-16.so(_ZN4llvm14FoldingSetBase19FindNodeOrInsertPosERKNS_16FoldingSetNodeIDERPvRKNS0_14FoldingSetInfoE+0xb6) [0x7f5e143278e6]
/usr/lib/libLLVM-16.so(_ZN4llvm12SelectionDAG19FindNodeOrInsertPosERKNS_16FoldingSetNodeIDERKNS_5SDLocERPv+0x36) [0x7f5e14e9b1b6]
/usr/lib/libLLVM-16.so(_ZN4llvm12SelectionDAG7getNodeEjRKNS_5SDLocENS_8SDVTListENS_8ArrayRefINS_7SDValueEEENS_11SDNodeFlagsE+0x23d) [0x7f5e14ee79cd]
/usr/lib/libLLVM-16.so(+0x3a0e816) [0x7f5e1700e816]
/usr/lib/libLLVM-16.so(_ZN4llvm16SelectionDAGISel14LowerArgumentsERKNS_8FunctionE+0xef3) [0x7f5e14e8f453]
/usr/lib/libLLVM-16.so(_ZN4llvm16SelectionDAGISel20SelectAllBasicBlocksERKNS_8FunctionE+0x22dc) [0x7f5e14f0632c]
/usr/lib/libLLVM-16.so(+0x19079b6) [0x7f5e14f079b6]
/usr/lib/libLLVM-16.so(+0x12ea945) [0x7f5e148ea945]
/usr/lib/libLLVM-16.so(_ZN4llvm13FPPassManager13runOnFunctionERNS_8FunctionE+0x459) [0x7f5e145ab989]
/usr/lib/libLLVM-16.so(+0x282aefa) [0x7f5e15e2aefa]
/usr/lib/libLLVM-16.so(_ZN4llvm6legacy15PassManagerImpl3runERNS_6ModuleE+0x3ec) [0x7f5e145ac6ac]
/usr/lib/dri/radeonsi_dri.so(+0x82f380) [0x7f5dba82f380]
/usr/lib/dri/radeonsi_dri.so(+0x84beb5) [0x7f5dba84beb5]
/usr/lib/dri/radeonsi_dri.so(+0x84d3b1) [0x7f5dba84d3b1]
/usr/lib/dri/radeonsi_dri.so(+0x863db3) [0x7f5dba863db3]
/usr/lib/dri/radeonsi_dri.so(+0xd1c1d) [0x7f5dba0d1c1d]
/usr/lib/dri/radeonsi_dri.so(+0x11ca0c) [0x7f5dba11ca0c]
/usr/lib/libc.so.6(+0x8c9eb) [0x7f5e05eaa9eb]
/usr/lib/libc.so.6(+0x1107cc) [0x7f5e05f2e7cc]

Python backtrace

Does anyone have an idea what to make out of this?
Thanks

try a different driver, amdvlk if you are using radv

Got the same Issue. . . .

Rich :wink:

Blender also stopped to work on my end. Lots of people seem to have the same problem.

https://www.reddit.com/r/blender/comments/16981n5/blender_wont_open_arch_linux/

We need to wait for a update or compile ourself with the good flags, in the meantime i use the Flatpak version.

Blender got a rebuild, try again now.
It seems to be a problem with blender, openshadinglanguage and AMD GPUs, check the discussion here:

you can try with the AMDGPU PRO drivers, to check if this resolves the matter:
https://wiki.archlinux.org/title/AMDGPU_PRO
and run it like this:
progl blender
or update to latest branch of openshadinglanguage and rebuild blender from source
or wait for the maintainers to provide an updated solution.

I see. Didn’t catch that. Thanks for the hint!

1 Like

Works with. . . . progl blender . . . . after installation of amdgpu-pro.

Rich;)

1 Like

Good to know. Since it’s not super urgent for me I will just wait for the solution they will come up with.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.