Black screen tearing problem

Hello, not sure if it belongs to kernel and hardware, but I seem to be having a black screen tearing issue.

I tried turning on variable refresh rate and tear free to on.

I captured the issue on video, here:

Only 2 things resolve this.

  1. Turn the monitor off and on. (This sets it to 1440p @ 60 hz)

  2. Change resolution and refresh rate to 1080p @ 60 hz then back to its native 1440p @ 75 hz

Deal is, I shouldn’t have to do this. Is there at least a way to somehow automate this?

The issue persistent on Manjaro Gnome, so it isn’t EndeavourOS specific, but maybe someone knows a solution.

My GPU is RX 580, I use default AMDGPU drivers.

using wayland in gnome or Xorg ?

I use xcfe/X11 now, the problem persists.

I though it was Gnome, it wasn’t.

ok for now i dont know , i got a vega 11, dont have it, and its weaker then rx580 probably :slight_smile:

you can try this :

create 20-amdgpu.conf in /etc/X11/xorg.conf.d/ if it isn’t any of them , copy the example

at : under the driver side : Option “TearFree” “true”

opfully is works, mayby its switched off somehown standard should be on as on wiki ?

I did a bit more trial and error, all combinations of “Variable Refresh Rate” and “TearFree”

Even manually adding 75 hz modeline, X didn’t even start on that.

I also tried setting display mode via kernel parameter. X sets it back to 60 hz.

Btw, how to set default refresh rate? It always goes back to 60 Hz.

i dont know, looked intoo radeon-profile didnt see also no option, its handy how to see about your gpu btw :slight_smile: temp / freq , power save such things overclocking…

changing Hz is also your monitor…weong herz it does not show property …

dont know dri=3 wil help but if gnome tears… compositor is mostly better… Xfce for some does and other not, so i cant tell…