Black Screen on Boot Up that Never reaches Login screen

yeah, same issues, started like two weeks ago still on 6.3.9, can’t wake from sleep sometimes.

post you journal with journalctl -xb -$numberofboot | eos-sendlog

you can get the boot number from journalctl --list-boots


Here is a journal of an affected boot

are you sure? looks like it was shut down properly.

I’m fairly sure. Thing is the boot doesn’t crash into a shutdown or anything, systemd loads a bunch of modules and stuff, then the screen quickly flashes in low resolution and then a black screen. From this point the computer is on, the keyboard backlight is on and such, but not interactive for the most part. I’ve tried stuff like ctrl-alt-f2, also made some attempts to use my normal shortcuts to login and go into the terminal and execute commands to check if it was just a display error and everything else was working, with no success. The reason the logs show a normal shutdown is because from this state the only option I’m left with is to press the power button, which seems to execute a normal shutdown.

In trying to fix the bug I’ve tried downgrading kernel to lts, 6.3.9, I’ve added nvidia modules to dracut to force them to load early, tried changing the lightdm option to await gpu driver before loading, disabled modesetting, switched display manager, switched nvidia driver. No effect from any


same but I just restored from an older clone backup…and now I am afraid to upgrade anything until they fixed the kernel issue …

For a time this past week the new updates seemed to have fixed the issue for me. But now, with this latest batch of updates from yesterday and today it seems that the black boot screen has shown up again at varying intervals when I turn on my machine.

1 Like

I just moved to linux-lts and linux-lts-headers on my four machines and haven’t had any further problems.


Tried 6.4.3, happened right after reboot. Is there a bugreport for this somewhere?

I keep seeing this message, people got this when starting wayland.
Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1

Also this:
amdgpu: SRAT table not found

Didn’t find anything useful what’s recent. Looks like a new bug.

1 Like

I’ve downgraded to 6.3.9 and still dealing with the issue.

I’ve also moved to linux-lts and linux-lts-headers and can boot successfully every time.

I’m a little bit confused…once I get my 6.3.9 booted, if I run

sudo pacman -Syu

then it says Starting full system upgrade… followed by there is nothing to do. However, I can see that my kernel version is 6.3.9. Shouldn’t it try to install the more up-to-date kernel when I attempt a system update?

1 Like

yes im on AMD Asus laptop with nvidia GPU…I had to rollback to 6.1.35-1-lts and that is ok…i am afraid to update now…wonder if it has been resolved

1 Like

I have now fixed my own issue, just kept looking through common solutions to this problem and trying other things. What finally worked for me was, having a laptop with both integrated and nvidia card, installing envy and setting it to only using the nvidia graphics card, not hybrid. I had at first discarded this because similar common solutions like blacklisting the integrated graphics card seemed to brick my os entirely, but this ended up working.

yeah something’s up with the amdgpu

1 Like

Sorry to enter a thread that does not belong to me, but I have the same problem. Has anyone been able to solve it?

I’m new to linux, I used the yay command and upgraded this morning EOS, but when I reboot I get all the confirmations with green letters saying OK, as usual, but it gets stuck on one of these OK notifications, and I can’t get there to the login screen.

Our friends in the forum are helping me, I have learned today to use the arch-chroot a bit, I don’t know if I did it correctly but I have obtained this.

[liveuser@eos-2023.05.28 ~]$ sudo mount /dev/sda4 /mnt/boot
mount: /mnt/boot: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
[liveuser@eos-2023.05.28 ~]$ sudo mount /dev/sda4 /mnt
[liveuser@eos-2023.05.28 ~]$ sudo mount /dev/sda4 /mnt/boot
[liveuser@eos-2023.05.28 ~]$ sudo arch-chroot /mnt
[root@EndeavourOS /]# journalctl -b -0 | grep fail | eos-sendlog
==> eos-sendlog: warning: nothing to send.
[root@EndeavourOS /]# grep -i upgraded /var/log/pacman.log
[2023-07-12T16:17:18+0200] [ALPM] upgraded alsa-card-profiles (1:0.3.73-1 -> 1:0.3.73-2)
[2023-07-12T16:17:18+0200] [ALPM] upgraded systemd-libs (253.5-2 -> 253.6-2)
[2023-07-12T16:17:18+0200] [ALPM] upgraded systemd (253.5-2 -> 253.6-2)
[2023-07-12T16:17:19+0200] [ALPM] upgraded dracut (059-1 -> 059-2)
[2023-07-12T16:17:19+0200] [ALPM] upgraded fakeroot (1.31-2 -> 1.32-1)
[2023-07-12T16:17:19+0200] [ALPM] upgraded libpipewire (1:0.3.73-1 -> 1:0.3.73-2)
[2023-07-12T16:17:19+0200] [ALPM] upgraded pipewire (1:0.3.73-1 -> 1:0.3.73-2)
[2023-07-12T16:17:19+0200] [ALPM] upgraded pipewire-audio (1:0.3.73-1 -> 1:0.3.73-2)
[2023-07-12T16:17:19+0200] [ALPM] upgraded pipewire-jack (1:0.3.73-1 -> 1:0.3.73-2)
[2023-07-12T16:17:19+0200] [ALPM] upgraded mesa (23.1.3-1 -> 23.1.3-2)
[2023-07-12T16:17:20+0200] [ALPM] upgraded firefox (115.0.1-1 -> 115.0.2-1)
[2023-07-12T16:17:20+0200] [ALPM] upgraded fwupd (1.9.2-2 -> 1.9.3-1)
[2023-07-12T16:17:21+0200] [ALPM] upgraded groff (1.23.0-1 -> 1.23.0-2)
[2023-07-12T16:17:21+0200] [ALPM] upgraded grub (2:2.06.r591.g6425c12cd-1 -> 2:2.12rc1-1)
[2023-07-12T16:17:22+0200] [ALPM] upgraded gst-plugin-pipewire (1:0.3.73-1 -> 1:0.3.73-2)
[2023-07-12T16:17:22+0200] [ALPM] upgraded inxi ( ->
[2023-07-12T16:17:22+0200] [ALPM] upgraded linux (6.4.2.arch1-1 -> 6.4.3.arch1-1)
[2023-07-12T16:17:24+0200] [ALPM] upgraded linux-headers (6.4.2.arch1-1 -> 6.4.3.arch1-1)
[2023-07-12T16:17:24+0200] [ALPM] upgraded pipewire-alsa (1:0.3.73-1 -> 1:0.3.73-2)
[2023-07-12T16:17:24+0200] [ALPM] upgraded pipewire-pulse (1:0.3.73-1 -> 1:0.3.73-2)
[2023-07-12T16:17:24+0200] [ALPM] upgraded systemd-resolvconf (253.5-2 -> 253.6-2)
[2023-07-12T16:17:24+0200] [ALPM] upgraded systemd-sysvcompat (253.5-2 -> 253.6-2)
[2023-07-12T16:17:24+0200] [ALPM] upgraded xorg-server-common (21.1.8-1 -> 21.1.8-2)
[2023-07-12T16:17:24+0200] [ALPM] upgraded xorg-server (21.1.8-1 -> 21.1.8-2)
[2023-07-12T16:17:24+0200] [ALPM] upgraded xterm (383-1 -> 384-1)
[2023-07-14T19:14:59+0200] [ALPM] upgraded alsa-card-profiles (1:0.3.73-2 -> 1:0.3.74-1)
[2023-07-14T19:14:59+0200] [ALPM] upgraded eos-translations (23-22 -> 23-23)
[2023-07-14T19:14:59+0200] [ALPM] upgraded libnghttp2 (1.54.0-1 -> 1.55.0-1)
[2023-07-14T19:14:59+0200] [ALPM] upgraded harfbuzz (7.3.0-2 -> 8.0.1-1)
[2023-07-14T19:14:59+0200] [ALPM] upgraded harfbuzz-icu (7.3.0-2 -> 8.0.1-1)
[2023-07-14T19:14:59+0200] [ALPM] upgraded eos-bash-shared (23-20 -> 23-22)
[2023-07-14T19:14:59+0200] [ALPM] upgraded eos-hooks (1.14-1 -> 1.15-1)
[2023-07-14T19:14:59+0200] [ALPM] upgraded fakeroot (1.32-1 -> 1.32.1-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded libpipewire (1:0.3.73-2 -> 1:0.3.74-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded pipewire (1:0.3.73-2 -> 1:0.3.74-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded gst-plugin-pipewire (1:0.3.73-2 -> 1:0.3.74-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded pacman-contrib (1.9.0-1 -> 1.9.1-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded pipewire-audio (1:0.3.73-2 -> 1:0.3.74-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded pipewire-alsa (1:0.3.73-2 -> 1:0.3.74-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded pipewire-jack (1:0.3.73-2 -> 1:0.3.74-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded pipewire-pulse (1:0.3.73-2 -> 1:0.3.74-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded poppler (23.06.0-1 -> 23.07.0-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded poppler-glib (23.06.0-1 -> 23.07.0-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded poppler-qt5 (23.06.0-1 -> 23.07.0-1)
[2023-07-14T19:15:00+0200] [ALPM] upgraded sudo (1.9.13.p3-1 -> 1.9.14.p1-1)
[root@EndeavourOS /]# 
1 Like

do you have an amd gpu? right now th only solution is to use the lts kernel


The 6.1.35-1-lts kernel I restored from a clone backup works fine. Not sure if you want to downgrade to that kernel or other that might work? I think there is definitely a bug in the new kernel updates that messed the nvdia driver or something.
(I’m on Asus vivobook
CPU: AMD Ryzen 7 5800H with Radeon Graphics (16) @ 3.200G
GPU: AMD ATI Radeon Vega Series / Radeon Vega Mobile Seri
GPU: NVIDIA GeForce RTX 3050 Ti Mobile )

1 Like

Hi friend, thanks for answering.

My pc is an i-5 3470, nvidia gtx 1050 ti, 8gb ram, gigabyte motherboard

LTS kernel, how do I install that, from the arch-chroot?

Or do you want to say that there is an official version of EndeavourOS LTS, like Ubuntu LTS?

Sorry I’m new to linux and I’m learning new things every time I get errors.

1 Like

How can I downgrade the Kernel, should I do it from the arch-chroot or something?

Sorry, I’m new to Linux and every day I learn something new when I try to fix new bugs.

1 Like

How can I downgrade the Kernel, should I do it from the arch-chroot or something?
Sorry, I’m new to Linux and every day I learn something new when I try to fix new bugs.

I’m not sure exact steps, but I am sure others here with more expertise than me will be able to show you? @Cphusion or anyone any idea? Seems @nicknick has similar issue we talked about?,…

1 Like

Thank you very much to all friends, one of our friends from our forum has managed to solve my problem, I leave here the link of my thread, maybe this can help to solve the problem of this thread too! :smiley:

1 Like

Well done…So this was your solution in the end right? EndeavourOS gets stuck at system boot after using yay - #24 by joekamprad

1 Like