Black Screen Following Plasma Wayland Session Start

I updated my EndeavourOS installation, but when I rebooted it, Plasma Wayland, which worked before the system update flawlessly, now goes straight to a black screen and ctrl+alt+f2 does not work and it requires a hard reboot to fix. Now only X11 works, albeit not well.

nvidia-drm.modeset=1 and egl-wayland are set, but I still cannot get Wayland to work anymore. Did something happen with a recent update?

No help, but all working here. Can you supply some hardware info?, very difficult to suggest anything without it, and check your logs.

Also - what kernel? I had some issues with Zen (all working now), but not with the standard kernel, but I think it was self-inflicted, but may not of been. And finally, I assume grub, but what mkinit system? Dracut or mkinitcpio?

Oh sure. The only problem is ctrl + alt + f2 doesn’t give me a usable tty. And wayland is completely broken.

I am using an AMD Ryzen 7950X & Nvidia RTX 4090 custom built desktop BTW. Stock kernel. Again, cant see which one because I can’t get past SDDM and the ttys are frozen.

I cannot seem to get any farther, but I’ll try using the iGPU and see I can get into Wayland or a tty. X11 wasn’t any improvement.

Finally, personally, I don’t think that attitude with the “all work and no help” will help attract new users to Linux. And I was in the middle of a Zoom meeting and had to use my laptop because Linux was unusable, so I was kind of rushing to get on the meeting.

1 Like

Welcome to the forum

Now in order for the nice people here to help you, returning what inxi -FAZ --no-host provides and paste it here in a Preformatted text. You can do that in X11 as well.
Further information about providing good information can be found here:

What I meant was it is working here which is no help.

I have a Ryzen 7 5800H with an RTX3070.

So is this a dracut install? because I found that in my case I had to exclude the nVidia drivers from the init.

It sounds like you are frustrated here because what @xircon said only was that he can’t be much help all is working for him. Then he asks for some hardware info and logs in order to try to help with your issue.

So i think you are being disrepectful with this comment. No one has given any attitude in my opinion.

1 Like

The biggest global level change that happened recently was a glibc bump.

Maybe try downgrading glibc for now.

Maybe I misinterpreted @xircon 's comment. Though it doesn’t help though that some other Linux forums (not this one) are kind of rude. If it sounds like I was a bit hasty to come to a conclusion, it’s because I’m getting fed up with Nvidia 4000 series & AMD Radeon 7000 series GPUs and their Linux drivers being completely broken in completely different ways.

Anyways, I am currently trying to get into the system with the AMD iGPU.

I’ll run inxi -FAZ --no-host when I get back into the system.

Edit: Plasma X11 works; running inxi -FAZ gives me the following:

inxi -FAZ

Host: REMOVED for security Kernel: 6.1.9-arch1-2 arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.26.5 Distro: EndeavourOS
Type: Desktop System: ASUS product: N/A v: N/A serial:
Mobo: ASUSTeK model: ROG STRIX X670E-E GAMING WIFI v: Rev 1.xx
serial: UEFI: American Megatrends v: 0705
date: 10/05/2022
Info: 16-core model: AMD Ryzen 9 7950X bits: 64 type: MT MCP cache:
L2: 16 MiB
Speed (MHz): avg: 3087 min/max: 3000/5880 cores: 1: 3000 2: 3000 3: 3000
4: 3000 5: 3000 6: 4500 7: 3000 8: 3000 9: 2985 10: 3000 11: 3000 12: 3000
13: 3000 14: 3000 15: 4316 16: 3000 17: 3000 18: 3000 19: 3000 20: 3000
21: 3000 22: 3000 23: 3000 24: 3000 25: 3000 26: 3000 27: 3000 28: 3000
29: 3000 30: 3000 31: 3000 32: 3000
Device-1: NVIDIA AD102 [GeForce RTX 4090] driver: nvidia v: 525.85.05
Device-2: AMD Raphael driver: amdgpu v: kernel
Device-3: Logitech BRIO Ultra HD Webcam type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7 driver: X:
loaded: modesetting,nvidia dri: radeonsi gpu: nvidia,nvidia-nvswitch
resolution: 1: 3840x2160 2: 3840x2160
API: OpenGL v: 4.6.0 NVIDIA 525.85.05 renderer: NVIDIA GeForce RTX
Device-1: NVIDIA AD102 High Definition Audio driver: snd_hda_intel
Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
Device-3: Logitech BRIO Ultra HD Webcam type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
Device-4: ASUSTek USB Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.1.9-arch1-2 running: yes
Sound Server-1: PipeWire v: 0.3.65 running: yes
Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi
IF: wlan0 state: up mac: f4:26:79:6a:cc:e1
Device-2: Intel Ethernet I225-V driver: igc
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: a0:36:bc:ac:ac:3e
Device-1: Intel AX210 Bluetooth type: USB driver: btusb
Report: rfkill ID: hci0 state: up address: see --recommends
Local Storage: total: 14.55 TiB used: 44.73 GiB (0.3%)
ID-1: /dev/nvme0n1 model: PCIe SSD size: 7.28 TiB
ID-2: /dev/sda vendor: SanDisk model: ST8000DM004-2CX188 size: 7.28 TiB
ID-1: / size: 6.59 TiB used: 44.73 GiB (0.7%) fs: btrfs dev: /dev/nvme0n1p7
ID-2: /boot/efi size: 499 MiB used: 612 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p5
ID-3: /home size: 6.59 TiB used: 44.73 GiB (0.7%) fs: btrfs
dev: /dev/nvme0n1p7
ID-4: /var/log size: 6.59 TiB used: 44.73 GiB (0.7%) fs: btrfs
dev: /dev/nvme0n1p7
ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%)
dev: /dev/nvme0n1p6
System Temperatures: cpu: 46.8 C mobo: N/A
Fan Speeds (RPM): N/A
GPU: device: nvidia screen: :0.0 temp: 35 C fan: 0% device: amdgpu
temp: 37.0 C
Processes: 570 Uptime: 5m Memory: 30.5 GiB used: 3.38 GiB (11.1%)
Shell: Bash inxi: 3.3.24

I also don’t know if this helps, but running nvidia-inst wants me to remove a package that is required by Steam: lib32-nvidia-utils I cannot remove it without removing Steam first, so I haven’t tried it yet.

Nvidia drivers are already installed not sure why you want to run nvidia-inst If you installed using the nvidia latest cards on the menu it installs nvidia drivers.

API: OpenGL v: 4.6.0 NVIDIA 525.85.05 renderer: NVIDIA GeForce RTX

I see you are using kde with Wayland. Rendering is being done on the nvidia graphics which don’t work well with Wayland. You may be better to switch to xorg.

Although Wayland does work well on Kde I’m not so sure that it does so on Nvidia. It seems to me that Wayland really caters to Gnome. Nvidia on the other hand caters to Windows. You can get a good experience with Wayland on Kde don’t get me wrong but i think it would be with xorg.

Edit2: I’m not saying that nvidia doesn’t work and maybe some other users who have Nvidia and are using Wayland could let you know their experience. You also high some very high end hardware that it is running on.

My experience, it works, occasional minor artefacts. Cannot screenshot the artefacts.

@cameron is this dracut or mkinitcpio?

What do you have in GRUB_CMDLINE_LINUX_DEFAULT in your grub config?

I’m using dracut. And before a recent update, it worked super well. Then a few days ago (the day before I made this post), it stopped working.

I have the following in my GRUB_CMDLINE_LINUX_DEFAULT:

nowatchdog nvme_load=YES resume=UUID=c4b29176-f84d-45d1-a338-4d3f7a08f103 loglevel=3 nvidia-drm.modeset=1

Also, the systemd screen is frozen when I restart; this has been happening since I installed Linux on this desktop.

I had to exclude the nVidia drivers from the dracut build:

Create /etc/dracut.conf.d/nvidia.conf

# Omit the nvidia driver from the ramdisk, to avoid needing to regenerate
# the ramdisk on updates.
omit_drivers+=" nvidia nvidia-drm nvidia-modeset nvidia-uvm "

Rebuild your mkinitcpio and reboot. If it doesn’t work remove the file and rebuild again.

Your grub looks similar to mine:

GRUB_CMDLINE_LINUX_DEFAULT="nvidia-drm.modeset=1 nohpet quiet resume=UUID=9d4e515c-9542-43fb-8175-1b1f8f27b762 loglevel=3 nowatchdog nvme_load=YES"

Unfortunately, this is an oldish install, I don’t use systemd boot, don’t know much about it.

Added the file, I’m rebooting. Let’s see how it goes!

Edit: Still a black screen with no output to the monitor. Should I remove the file?

Did the dracut-rebuild work? (BRB need to reboot after update).

Check which packages were updated/installed since that update. Maybe one of them has a bug.

If the issue is with a new Plasma package update, maybe it is a configuration problem in the user account.
Create a new user account and login to that in Plasma Wayland, to check for improved behavior.

You may also try installing and booting to linux-lts.

FWIW, if there is a partial update situation, it may explain any troubles. I mean this:

Maybe they also try sddm-git?

The point is that Plasma Wayland was working fine before OP posted.
sddm-git is a workaround (if it solves the issue :wink: ).

I do find it weird that another laptop I have with an AMD Ryzen 5900HS & an RTX 3050 Ti (though stuck on Optimus) does work fine, but it seems to be an issue with RTX 4000 GPUs. And I find even more weird that it did work then just stopped after an Nvidia driver update and a reboot later.

Apart from your findings :smile_cat: will you try any suggestion, or keep troubleshooting?
My PCs work fine :wink: .

I think it might be something to do with the Nvidia drivers for RTX 4000. I installed Garuda Linux on the same desktop, with the same black screen results on Wayland. I think I’m just going to use X11 on it for a bit longer…

F**king Nvidia and their proprietary :poop:… If only they open-source more of their drivers and took Linux seriously like Intel & AMD do…