Black Screen After Wake Up from Suspend - Kernel 5.15(?)


I just switched from Ubuntu to EndeavourOS. Previously, Ubuntu worked outta the box and everything functioned very well, but I’ve had issues with waking up from a Suspend state within both Manjaro and Fedora systems.

I’ve tried several DE’s for Endeavour (such as KDE, Xfce, and GNOME (with which have all had the issue of not being able to wake up from a Suspend state. Once woken up, the keyboard and power-button light up but the screen remains black and unresponsive.

Output for neofetch:

Output for inxi --full:

I’ve tried many solutions within the forums but I haven’t been able to solve my problem (blacklisting nouveau, switching to lts kernels, creating a swap file, etc.). I’m still fairly new to Linux and this is the first time I’ve ever reached out on a forum but I’m really interested to use Endeavour and an Arch-based distro so I’m excited to see what I’m able to do.


have you try kernel linux 6.0 or 6.1 ?


I imagine I have. I’ve tried the command: sudo pacman -Syu linux which reveals this output:

I’ve also tried the default kernel, LTS kernel, and ZEN kernel. They all have had the same issue. Thank you for replying!