Black screen after updating to 5.17 kernel

As the title says, I get a blackscreen after the EOS grub menu. I had to revert back to 5.16 since the issue is not present there.
I’m using a Nvidia GTX 1060ti and the nvidia 495 linux driver, with nvidia dkms and all of this properly installed, so I don’t have a clue whats the problem exactly. My laptop is NOT optimus compatible so that’s not the issue either.

Why are you not using the 510xx series drivers on Nvidia?

It gives me a major performance regression when gaming (fps drop to 0 after a couple of minutes playing)
It happened with every game in every launcher, the 460-495 series do not have this issue so I stayed there. Is that the reason why I can’t upgrade to 5.17 kernel?

I’m not sure what the issue is. Maybe start with posting a link to your hardware.

inxi -Faz | eos-sendlog

Also (as a given) realize that 5.17 is the bleeding edge. Prepare to bleed and follow kernel development. And unless there’s something particular that you want in 5.17, maybe you should stick with 5.16 until 5.17 (or 5.18) matures a bit more?

I don’t have any rush in updating as I’m fine with 5.16. I was just wondering why upgrading to the next kernel version ended up in a Black screen… I don’t think that is supposed to happen.

My specs are as follows:

So when you update it updates fine? It just boots to a black screen? :thinking:

Yep, that’s exactly what happens.

I can only think it has something to do with Gnome? But i don’t want to lay blame because i don’t know. There is no reason because the 1060 Nvidia card is fine. It’s supported on the driver you are using as well as the latest driver. I have an Nvidia GTX 1060 desktop card myself. But is running on Xfce. I haven’t updated to 5.17 kernel yet i don’t think. I’ll have to check but I don’t think there will be an issue.

I’m kinda with Rick, though I probably think it’s Nvidia and a changed kernel interface…but you never know what regressions sneak in.

I also agree that it might be something Nvidia related. For now, best bet is to wait and see what happens.
The performance regression, although annoying, does not happen in 495 so I’ll stay on that for the time being.

This means you’re holding back a package that hasn’t been updated with support for kernel 5.17.

Either update to 510xx or switch to 470xx from the AUR.

Either the Nvidia driver or the dock (if any). Each time I get a kernel update, I don’t reboot but rather shutdown and then power on anew. Alternatively I risk a blinking screen, and then waking up in 0.5 hour, without any wired network connectivity. Besides, some NFS functionality got patched in 5.16, and broken in 5.17.1, here to stay (5.17.2 still has it) Why, oh why does all this shit happen only to me :-(?

I just got the same issue after update. Tried reinstalling nvidia drivers, didn’t work.
Logs -
Please help

I had that problem too.

I do not have an Nvidia-graphics. Problem seems to be Xorg in combination with the latest kernel (5.17.2).

You can go to a TTY by hitting CTRL + ALT + F2 (e.g.).

Then you can login with your user and do the following:

sudo dmesg --level=err

You will see something like

BUG: scheduling while atomic: Xorg ...

If that is the case, you can resolve the error by downgrading to an earlier kernel:

sudo downgrade linux
sudo downgrade linux-headers

See also for reference.

The previous version, 5.17.1 worked for me. After a reboot, everything was back to normal.
The bug will probably resolved soon, I guess, but I will stick to this version for the next days :slight_smile:

Could you please write the complete error line here? I forgot to save it somewhere…

Especially for Nvidia users I recommend the following:

  • Use the dkms version of the Nvidia driver (including kernel headers).
  • Install linux-lts and linux-lts-headers as a fallback kernel.

Terminal commands should be something like this:

sudo pacman -Syu nvidia-dkms linux-headers linux-lts linux-lts-headers --needed

This way the LTS kernel can be used as a fallback if the default kernel has a problem with the Nvidia drivers. The default kernel will likely get fixed in the following updates.

5.17.2-zen3-1-zen is working fine for me with NVIDIA drivers so it’s likely something specific to those systems.

Also the default linux kernel 5.17.2.arch3-1 works here with driver nvidia-dkms 510.60.02-1.

Often the first linux release series, including 5.17, causes a black screen here. Then I simply switch to linux-lts. This time the first point release, linux 5.17.1 fixed it.

1 Like