Black screen after update

So, I’m using KDE on a macbook air from 2013. I ran an update today and I can log in, but as soon as I open anything, 5 seconds later the panel+background go black.

If I opened anything in that 5 seconds, that stays on screen. I can still log out by pressing my shortcuts and then log back in and the same thing happens.

I’m not sure what to do.

downgrade mesa and eventually mesa-vdpau try to reach TTY ctrl-alt-f(x)

downgrade mesa mesa-vdpau or only mesa, mesa is the issue

1 Like

This worked, thank you

Mesa was fixed in 20.0.7-2

https://bugs.archlinux.org/task/66666

2 Likes

Hello how are you? I’m Christian, I am new to Arch, Endeavouros was recommended and I installed it on a notebook, the installation was successful, I did an offline installation, but after updating the system and restarting, I always end up on a black screen and the cursor … I can move with the ctl + alt + f … but later I don’t know how to continue to see what is generating the error …

I found this post from manajaro, but I wouldn’t know how to apply it to solve the problem …

Can any one guide me ???

Thank you in advance! and super happy to have been able to install after trying the live on this excellent system !!

https://forum.manjaro.org/t/pantalla-negra-no-funciona-servicio-light-display-manager-solucionado/81712/7

what exactly is your DE (Desktop Environment) and are you installing any bumblebee PRIME dualgraphics stuff? or Nvidia?
Interesting also to get specs and logs:

First, thank you very much !!
Second, I am going to use the given commands to see if the error can be traced.

Install offline only with XFCE, update the system, reboot and I just couldn’t do anything else because the black screen appeared with the cursor.

I hope this data helps, and I am attentive to any questions.

I can’t put more than 2 links

Logs

Hardware Information System

Using inxi -Fxxc0 | curl -F 'f:1=<-' ix.io

Systemd Journal

add http to access the link …

Journal : [http://ix.io/1QsR]
Journal last: [http://ix.io/1VrU]
Journal 2last: [http://ix.io/1Qsu]

Xsession

http://ix.io/1YzS

http://ix.io/1YA1

Xorg (X11)

http://ix.io/1YzR

Lightdm

Christian

(xfce4-panel:857): libxfce4ui-WARNING **: 20:06:44.153: ICE I/O Error

only thing i can see is this…
try removing .ICEauthority:
boot up to blackscreen with cursor,
press [Ctrl+alt+F2] login as normal user and:

rm ~/.ICEauthority

and restart lightdm:
sudo systemctl restart lightdm

Sorry, this week I was very busy at work.
Try what you tell me, and the same thing is still happening, and giving the same error where you marked it … I am already thinking that it can become the notebook …