Black screen after sleep, (Mesa Intel TigerLake-LP GT2, i915)

I keep having trouble with my new laptop LG Gram 17, with EndeavourOS installed. After the laptop has been in sleep mode the screen will just stay with a flickering black screen after it wakes up.
Once in a while, I can see a short glimpse of the correct screen, either the login screen if the screen locker is enabled or the correct desktop.

I have installed the latest version of EndeavourOS around the 10. of January with the KDE package selection. And kept the system up to date daily.
Until the latest update of the plasma platform (5.24.0-1) the problem could be solved by using wayland instead of X11. But after the last update, the Wayland version has the same problem.

I have tried to disable the lock screen to see if it was causing the problem, but the problem persists, just with the correct screen in climbs.
Tried changing tty, without any effect at all.
Tried reinstalling mesa, (and a lot of other packages) without any luck.

From my Xorg.0.log i have:
[ 26.613] (II) modeset(0): EDID vendor “LGD”, prod id 1685
[ 26.613] (II) modeset(0): Printing DDC gathered Modelines:
[ 26.613] (II) modeset(0): Modeline "2560x1600"x0.0 268.64 2560 2608 2640 2720 1600 1603 1609 1646 +hsync -vsync (98.8 kHz eP)
[ 388.489] (WW) modeset(0): hotplug event: connector 308’s link-state is BAD, tried resetting the current mode. You may be leftwith a black screen if this fails…


Anybody with an idea, how to solve the issue. Or suggestion where to look?