Black screen after installing nvidia drivers

I installed EndeavourOS on my laptop HP Elitebook 8560w with built-in video card NVIDIA Quadro 1000M. I followed this guide to install nvidia drivers:

I run first this command sudo nvidia-installer-dkms -f, and after that i run yay -S nvidia-390xx-dkms but after rebooting i got black screen. I guess i did something wrong but not sure what.

Welcome aboard hope you enjoy you EOS install and the forums. Check this thread and see if it helps.

Is this a discrete GPU or a hybrid setup?

If you mean to comment out the line GRUB_DISABLE_SUBMENU=y in /etc/default/grub i did that, but it didn’t help.

No, it’s not a hybrid setup.

Welcome! :smile:

Just to make sure, can you show the output of:

  lspci -vnn | grep -P 'VGA|3D|Display'

This is the output:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108GLM [Quadro 1000M] [10de:0dfa] (rev a1) (prog-if 00 [VGA controller])


First of all, if nouveau driver works, you could use that during troubleshooting.
If you can use the TTY (press Alt-Ctrl-F2), you can uninstall nvidia drivers (sudo nvidia-installer-dkms -n) and reboot with nouveau.

There are lots of troubleshooting material:

1 Like