Black screen after failed update

EndeavourOS worked well after last big update of KDE Plasma.
Today there was an update that started downloading and installing and by mistake I shut down the computer and now EndeavourOS boots well but I get black screen instead of login screen.
I’m sure it is something with the graphics card (nvidia) since in the past on Manjaro I had many problems like these.
I guess the solution is something with chroot and updating but I need to know how to do it on Endeavour.
If some one can help or give a guide what to do.

Hello :wave:
I used this guide a coupe of weeks ago;

https://discovery.endeavouros.com/system-rescue/arch-chroot/2022/12/

Best regards

1 Like

Ok.
I made the chroot.
Now I need to know how to update system.
I tried:
sudo pacman -Syyu
And what I get is:

::  Synchronizing package databases...
error: failed to synchronize all databases  (unable to lock database)

Ok.
Problem solved with this.

https://wiki.archlinux.org/title/Pacman#"Failed_to_init_transaction_(unable_to_lock_database)"_error

System is now updated.
System boots well but still I get a black screen after boot without login screen.
There must be another update related to the graphics card.

I run nvidia-inst and got an error:

root@EndeavourOS home]# su mango nvidia-inst
2024-03-12 02:27:05: Info: Running: nvidia-inst v23.1-1
2024-03-12 02:27:05: Info: Command line: nvidia-inst 
2024-03-12 02:27:06: Info: Selected mode: nvidia
lspci: Unable to load libkmod resources: error -2
lspci: Unable to load libkmod resources: error -2
NVIDIA card id: 1c03
Fetching driver data from nvidia.com ...
2024-03-12 02:27:09: Info: Disabling bumblebeed.service
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
COMMANDS TO RUN:
    systemctl disable bumblebeed.service
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

==> NOTE: running the commands may take several minutes...

Root Password: 
Failed to disable unit, unit bumblebeed.service does not exist.

Good morning :slight_smile:
You’ve been working hard ! :rescue_worker_helmet:

I use the free software driver for my machines on nvidia GPU it’s called “nouveau”.

For the proprietary driver, here is documentation; ( I have no experience with this :wink: )
https://discovery.endeavouros.com/category/nvidia/

My computer worked fine together with propriety Nvidia driver.
I made a mistake and shut down my computer while updating system.

So I guess this is the reason why I have black screen after booting.

I want to avoid reinstalling Endeavour all over again.

Hold on - a good person with proper knowledge will surely come in and ask for some logs and help you :technologist:

You have the best of good day! :penguin:

1 Like

Please show some of what you have currently installed:

pacman -Qs nvidia
pacman -Qs headers linux

The output shows some candidates you can try reinstalling, especially linux kernel(s) and the nvidia driver.

Since I got error saying

Failed to disable unit, unit bumblebeed.service does not exist.

I tried installing primus_vk 1.6.2-1 but it didn’t help so it is still written as installed.

pacman -Qs nvidia

local/bumblebee 3.2.1-21
    NVIDIA Optimus support for Linux through VirtualGL
local/egl-wayland 2:1.1.13-1
    EGLStream-based Wayland external platform
local/libvdpau 1.5-2
    Nvidia VDPAU library
local/libxnvctrl 550.54.14-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 550.54.14-4
    NVIDIA drivers - module sources
local/nvidia-hook 1.5-1
    pacman hook for nvidia
local/nvidia-inst 23.1-1
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings 550.54.14-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 550.54.14-4
    NVIDIA drivers utilities
local/opencl-nvidia 550.54.14-4
    OpenCL implemention for NVIDIA
local/primus_vk 1.6.2-1
    Nvidia Vulkan offloading for Bumblebee

pacman -Qs headers linux

local/linux-api-headers 6.7-1
    Kernel headers sanitized for use in userspace
local/linux-headers 6.7.9.arch1-1
    Headers and scripts for building modules for the Linux kernel
local/linux-lts-headers 6.6.21-1
    Headers and scripts for building modules for the LTS Linux kernel

So now try installing the kernels and some nvidia packages like nvidia-dkms.

How? :grinning:
At least a guide.
I’m not familiar well enough with the technical side of Linux.

Command like: sudo pacman -S "packages"

For example:

sudo pacman -S linux linux-lts nvidia-dkms

It looks too complicated for me.

sudo pacman -S linux linux-lts nvidia-dkms
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
  if you're sure a package manager is not already
  running, you can remove /var/lib/pacman/db.lck

First remove the lock file.
sudo rm /var/lib/pacman/db.lck

as the message suggests.

Thanks.
I reinstalled and booted the computer and still black screen.

Well, shutting down in the middle of an update may cause several problems that may take time to fix.
So reinstalling is probably faster.

But if you have personal data you want to keep, backup it first to an external drive.

1 Like

Well since the main error was:

Failed to disable unit, unit bumblebeed.service does not exist.

I gave it another try.
I mainly used some of what is written on this wiki and … it worked :grinning:
https://wiki.archlinux.org/title/Bumblebee
Thanks for the effort.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.