Been trying to set up sound for weeks, still no luck

Hi, I have been scouring forums and websites and guides for the last two weeks since I have installed endeavourOS because I cannot get any sound to come from my lap top so at this point I do not even know where to go anymore so I figured I will just directly ask here. I know the sound is unmuted and the system shows that there should be sound coming from my laptop if I am playing something but nothing comes out. I do have sof-firmware installed as well as ALSA and am running PipeWire. This is what comes up when I run inxi -Aa

Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard
driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel, snd_soc_skl, snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0401
Device-2: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen 3
class-ID: 0403
Sound Server-1: ALSA v: k5.18.14-arch1-1 running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes

1 Like

Hello @Stern , Welcome to EndeavourOS forum.

First up, let see whether sound is actually running but not coming out or not.

In terminal,

type speaker-test and return the output.


If it shows something like :

┬─[deweshk@HomeDesktop:~]─[09:33:30 PM IST]
╰─>$ speaker-test 

speaker-test 1.2.7

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 128 to 2097152
Period size range from 64 to 1048576
Using max buffer size 2097152
Periods = 4
was set period_size = 524288
was set buffer_size = 2097152
 0 - Mono

Time per period = 11.219079
 0 - Mono
Time per period = 11.007013
 0 - Mono
Time per period = 11.007174
 0 - Mono

Then speakers are working and issues are with PulseAudio.

Do you also have this installed?

alsa-ucm-conf

no I do not believe I do

edit: oops I lied, I actually do have it installed

Yeah so when I ran this other than the “Time per period” being slightly different from what you had everything is exactly the same

Your inxi -Aa looks good to me.

Are your speakers correctly plugged in? Have you tried with headphones? Is anything muted, or volume set to zero?

In that case, see this :

Link: https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture/Troubleshooting#No_output

So I did that and got this. So it isn’t using PulseAudio, correct? So I am honestly not sure where to go from there.

Well the speakers are internal, it’s a laptop. And I checked volume with alsamixer and it is at 100% and seems to be unmuted

by the way, bluetooth headphones work but i am not trying to use headphones every time i use my laptop however it is better than nothing

Is bluetooth turned off when trying to get sound from the speakers?

One more thing is written in screenshot, that is to kill the PulseAudio process, let’s see whether it helps.