BCM43-142A0 Bluetooth driver installation issuet

Thank you. It is on my reading list. If you find something that explains the difference and how they are enabled, I would appreciate. In the meantime, I will check the archwiki.

It is my Sabbath, so I will check again tommorw night.

Michael

I haven’t read every post in this thread, so maybe this has already been mentioned, but…

Since this worked for you previously on Manjaro, perhaps it’s not an issue with the broadcom-bt-firmware-git package, but something else?

The bluez package updated from 5.63 to 5.64 yesterday (and a bug report that appears relevant was just opened today); you could try downgrading to the previous version and see if it works.

1 Like

It’s strange as i am not having any issue with the updated bluez package on my hardware.

How did I miss that.
I will try soon.

@HMS_Endeavour

Modules Info

https://wiki.archlinux.org/title/Kernel_module

Systemctl Info

https://wiki.archlinux.org/title/systemd

@HMS_Endeavour

So there is an issue with the latest bluez bluez-utils package causing bloothtooth.service not to start in case you haven’t seen it. I’m not having this issue on my laptop with the latest package but many are. I’m not sure if this is related to your issue either but you might as well try downgrading those packages to try it. The post is pinned on the main page.

Edit: Looks like bluez bluez utils just got updated. :wink:

Thanks for the heads up on the bug report.
This is what it is building
broadcom-bt-firmware-git-12.0.1.1105_p3.r0.g68a7a8a-1
bluez is not installed, so are you suggesting I git clone bluez 5.63?
If so, how do I do this? Sorry for my ignorance but git clone from the AUR is my limit.

Michael

You’re running Gnome, right? bluez is a dependency of gnome-bluetooth, which is a dependency of gnome-control-center, which is a dependency of the Gnome group, so I’m surprised that you don’t have it installed.

I don’t use Gnome, but I would think you would want to install the gnome-bluetooth package, which should pull in bluez. At the very least you should install bluez:

sudo pacman -S bluez

Then install the AUR package for the firmware you are trying to install; if you prefer to manually build it, that’s fine, but you could use yay instead:

yay -S broadcom-bt-firmware-git

By the way, the bluez package has been patched, so it should be working fine now. There is no more need to downgrade it. Just install it if it’s missing, and if it is already installed be sure your system is updated.

Hi @ricklinux,
Results from journalctl
mars 19 20:50:17 eos22 systemd[16361]: bluetooth.service: Failed to set up mount namespacing: /run/systemd/unit-root/var/lib/bluetoot>
mars 19 20:50:17 eos22 systemd[16361]: bluetooth.service: Failed at step NAMESPACE spawning /usr/lib/bluetooth/bluetoothd: No such fi>
░░ Subject: Le processus /usr/lib/bluetooth/bluetoothd n’a pas pu être exécuté
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ Le processus /usr/lib/bluetooth/bluetoothd n’a pas pu être exécuté, et a donc échoué.
░░
░░ Le code d’erreur renvoyé est ERRNO.
mars 19 20:50:17 eos22 systemd[1]: bluetooth.service: Main process exited, code=exited, status=226/NAMESPACE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ An ExecStart= process belonging to unit bluetooth.service has exited.
░░
░░ The process’ exit code is ‘exited’ and its exit status is 226.
mars 19 20:50:17 eos22 systemd[1]: bluetooth.service: Failed with result ‘exit-code’.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ The unit bluetooth.service has entered the ‘failed’ state with result ‘exit-code’.
mars 19 20:50:17 eos22 systemd[1]: Failed to start Bluetooth service.
░░ Subject: L’unité (unit) bluetooth.service a échoué
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ L’unité (unit) bluetooth.service a échoué, avec le résultat failed.

systemctl status bluetooth

Michael

Yep, Gnome 41
I reinstalled gnome-bluetooth and gnome-control-center to be sure.
I installed bluez and broadcom firmware without any errors.


Still can’t activate bluetooth in Gnome.
What am I missing?

Michael

Did you start and enable the bluetooth service?

systemctl enable --now bluetooth

Thank you. It works :partying_face:

Michael

1 Like

Glad it’s working for you. I’m not that familiar with all the Gnome packages and the way Gnome works exactly with their set up. Everything is the same in the end it’s just the way to get there.

Edit: Thanks @Stagger_Lee

Thanks @ricklinux for your efforts. @Stagger_Lee nailed it, but what really shines is the EOS community.
Hopefully I will learn enough to be of help to others.

Michael

this is exactly looking like the current bug on bluez packaging… @Stagger_Lee mentioned…
https://forum.endeavouros.com/t/update-to-bluez-packages-5-64-2-causing-failed-bt-startup/25176/2

1 Like

It’s been patched as of yesterday, so it’s no longer a bug:

yes but the output of BT status I mentioned is exactly what the bug was causing :wink:
But thanks for the link I just update the post:

1 Like

I installed pamac-aur-git just in case.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.